LC #42 Pipers Alley

View Full Version : Fluid Sim - Issues

06-18-2012, 11:52 PM
I recently decided to create a waterfall simulation in Blender only to go half the way and be forced to stop. I've created the path which the water will follow from a plane and set it as an obstacle but no matter what I do the fluid keeps passing through and instead colliding with an invisible shape. No matter what resolution I've tried it refuses to work and I am on the brink of giving up. I have tried all three obstacle type options to no avail. I end up with the fluid becoming this as though there is some other object.

I thought maybe the fact that the path was a plane the fluid was passing through it so I used the solidify modifier and yet it still passes through. If anyone wants the file email me and I'll answer back. If anyone has suggestions it would be great.

06-19-2012, 04:06 PM
Can you post image of what's happening please?

06-19-2012, 04:35 PM
This is what was happening:

I exported the ground as an obj file then imported it into a new file, went into edit mode and pressed several different things which solved it but I retained the original problematic file because I want to know what the problem could've been so that if I ever come across it again I don't suffer problems.

06-19-2012, 07:29 PM
Have you tryed to apply the scale, location and rotation of all the objects.

06-19-2012, 08:54 PM
I'm completely new to this so how would I do that? I can't try it right now but I will later.


06-19-2012, 09:39 PM
ctrl+A. Apply them one at a time and see if they solve your problem. I say start with scale then rotation and then location.

06-19-2012, 10:43 PM
Also, find out where it's writing the cache files. I've had this happen, and have had to trace the cache files to a temp folder in some AppData folder that was hidden (on Windows). Find that cache, delete it, and see if it helps.

06-20-2012, 10:09 AM
I didn't want the fluid to be cached in some random place so I changed it's directory to a folder that is in the same folder as my .blend file. I deleted it's contents but that still didn't help. I'm going to try ChukChuk's suggestion once I am done with my fluid simulation. (Left it on overnight AND still not done)

CGTalk Moderation
06-20-2012, 10:09 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.