View Full Version : mix20layer issues

04 April 2012, 07:13 PM
I recently switched to 64bit and transfered all my old maya files to an SSD. Now I can't get mix20layer to work at all...

"API 0.0 error 301031: call to undeclared function "mix20layer"

I have searched various forums and have tried the following;

-Edit the .mi file
search for nodeid and change the number

-start maya and and look at the Shader Manager
repair what are not loaded

-1. Leave your maya.rayrc clean don't touch it !
2. Don't put anything in X:\Autodesk\Maya2009\mentalray\lib and X:\Autodesk\Maya2009\mentalray\include
3. add these variable to your OS
4. Create a folder and call i whatever you want like "CustomShader"
5. Create 02 floders inside it include and lib
6. Put the .mi file into the include folder and the .dll file into the lib folder
7. "xpm files" goes to : C:\Documents and Settings\Administrator\My documents\maya\2009\prefs\icons
8. "mel files" goes to :C:\Documents and Settings\Administrator\My documents\maya\2009\prefs\scripts

-Add these lines to your maya.rayrc file:

link "{MAYABASE}/lib/mix20layer.{DSO}"

mi "{MAYABASE}/include/mix20layer.mi"

None of these things seem to do anything. I always get the same error message.
I'm using Maya 8.0 64bit.

Thanks guys!

CGTalk Moderation
04 April 2012, 07:13 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.