XM Magdalena 3D print, GGeorgy (3D)
LC #42 Pipers Alley

View Full Version : indirect illumination with ao (render element) question

02-11-2012, 03:57 PM

I am having an issue while rendering:

"mr A&D Xtra Diffuse Indirect Illumination with AO"

as some of the elements appear full black and I am wondering why as in the beauty render they look ok?

-Also as a side question I have some issues with the glass "windows" as they get far from the camera some aliasing issues occur. My render settings for antialiasing are set to
4-16 mitchell with jitter turned on. Also using Max trace depth at 10 (5refl, 5refr)
The windows have those indents actually modeled so its a straight physical glass shader on them.

This is the raw render:
edit: higher res (http://dl.dropbox.com/u/4138955/drop3d/station_wip_v001.JPG)

and this the "mr A&D Xtra Diffuse Indirect Illumination with AO" where you can see the black objects..


Hope you can give me an idea, thanks in advanced.


02-11-2012, 04:22 PM
Have you checked which way the normals are facing on those objects? They may be reversed.

02-12-2012, 03:04 PM
Hello Tim,

I took a look at the normals and they looked ok. But then I tried simply recreating the same shader but with a new one and then applying it to the objects and it worked ok. I am not sure why this happens as the shader I recreate was exactly the same.

I think it might have something to do with the fact that I merged all the objects into my lighting scene. There might be some bug/error while merging both scenes, hence why some materials were behaving bizarrely.

Thanks for your time.

CGTalk Moderation
02-12-2012, 03:04 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.