View Full Version : Seems when baking AO

12 December 2011, 03:21 PM
Hey all,

I'm basically trying to find out if anyone has a definitive answer as to how you bake AO with mental ray WITHOUT getting any black UV seams, I've done a fair amount of searching already on the forums and have tried all the common responses (Making baked map x2 in size, Texture seems set to 3 etc) but nothing seems to work. I've even set the texture seams as far as 30 to no avail!

I can't believe mental ray simply cannot do this so I guessing it must be something I'm doing? I get seams even if I try and bake a cube, I mean REALLY??????

Any help would be greatly appreciated ;)



12 December 2011, 01:33 AM
1 u need proper UVs-from 0 nj 1 range and non overlaping. Automatic mapping for example quite good for it.
2 increase "fill texture seams" in bake option

12 December 2011, 09:33 AM
Yeah, like I said, all those things have been done/tried unfortunately with zero success. It seems as though everyone has to go into photoshop and fix them up :(

12 December 2011, 01:59 PM
Then everyone must be doing it wrong! Never had this problem before. Sorry I dont have any other ideas for you, its just always worked for me.

12 December 2011, 02:23 PM
So I just tried doing an AO bake on a default cube, the result can be seen below or attached. That was with all the right settings and "Fill Seams" set to 30!!! Could you try the same thing and see what you get?

As you can see, it struggles do even do a cube correctly!

12 December 2011, 02:29 PM
Hows it look rendered? Never trust the viewport.

12 December 2011, 02:57 PM
It renders exactly the same as the viewport :( . To be honest the rendered result is irrelevant anyway. I'm baking for use in a runtime environment so the viewport is actually much closer in line with how the assets will be rendered in the game engine anyhow.

12 December 2011, 07:28 AM
what value of occlusion distance?

02 February 2012, 04:15 PM
@ade90054: Did you find a solution? I have the exact same problems!

I'm working with Maya2012 SP2 on WIN7 64bit. Maybe it simply doesn't work with this version. Could please someone check this?

Thanks in advance

02 February 2012, 05:05 PM
Fill seams doesn't work with Single object. You have to use Multiple objects option (meaning 1 object will use 1 core to render... if you want to render only one object it will take 4 times longer if you have a quad core...).

02 February 2012, 08:53 AM
Bake Optimization: Multiple objects! That's it!
Chafouin, thanks for your hint.

CGTalk Moderation
02 February 2012, 08:53 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.