View Full Version : Error render up to 1200px

10 October 2011, 06:52 PM
Hi guys..
averytime I try render a resolution up to 1200px following error appears: "...: mental ray has encountered a fatal error condition.. It has been disabled for the rest of this XSI session..." after that gotta close the program.
someone know tell me what is causing it?
the render have "simple SSS". will be have to configure anything in the "render manager"?
or is hardware.. I have 3gb ram and CPU core 2 quad

help me..

10 October 2011, 09:24 PM
I think that the error is related to your simple SSS settings which cause Mental Ray to go berserk with its RAM consumption, resulting in a (internal) crash. To make sure of it, you could deactivate any volume calculations in the render settings. Also, you could activate the detailed logging so you can see what happens when.

10 October 2011, 05:30 AM
I think the error is because consumption of RAM with Simple SSS.
I did some tests with phong and lambert and rendered normal.
I activated the options palette render Option/ diagnostics/ logged menssages... but still giving the same error.

10 October 2011, 07:05 AM
The logging option should help you to determine when exactly the error should occur, meaning what MR is calculating at that moment. Sometimes this can give you vital information to solve the problem.

My guess is that you need to tweak your simple sss settings to lower MR's RAM consumption. Try working with the Scatter controls, especially the lightmap samples settings. Also tweak the light settings, especially when you're using area lights.

Here's an idea: lower all RAM related settings in the shader to the lowest and check whether or not MR crashes. If not, you can increase everything bit by bit. If MR still crashes open a new scene and apply simple sss to a sphere to see whether or not MR crashes then.

Hope that helps.

10 October 2011, 05:09 PM
I tried these and other options that some friends quoted in other sites foruns but nothing came of it.
I found that had once subdivided the mesh. imported of zbrush with 61,000 and a subdivision was to 243,000 +/-. so the error of the MR.
without subdivision with 61000 rendered.
I'm still a little suspicious of this error MR I think it has to do with the RAM.
As some have said in another forum that 243 000 triangles is still little to cause this error.
some print screen with scene setting. (

here the render with 1200px

10 October 2011, 08:34 PM
It looks like you're trying to render for print resolution? I've had trouble in the past with this, and crashing at these larger resolutions. You have a far better computer than I do, but you may consider rendering this in slices. Meaning, render the image in 100x3000, or 100x100 chunks. Create a series of passes, and render through all the passes. I haven't tested this myself, but perhaps it's a good direction for you.

10 October 2011, 09:21 PM
After looking at your render tree I think I know what might cause your crashing problem: the displacement mapping.

Some months ago I had the exact same problem. When I rendered a model in lower resolution everything was fine. As soon as I increased the rendered image resolution beyond a certain threshold Mental Ray caused problems. In my case it froze the system since Mental Rays memory consumption skyrocketed in mere seconds.

Although your problem is a little bit different try to disconnect the displacement branch and test whether or not mental ray renders your image. If it's working you know where to look. If that's not working you could y to connect the displacement and bump mapping branches directly to the defaultmat node and see what happens.

10 October 2011, 12:13 PM
3gb Ram is actually 2 GB in a 32 bit system.

I'll tell you what I tell everyone else that has Ram problems...get a 64 bit operating system and 12gb(or more).

CGTalk Moderation
10 October 2011, 12:13 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.