PDA

View Full Version : Keyfader in Compose


ljilekor
10-31-2003, 11:15 AM
I rigged my character with a FK_IK blender on the arms. To obtain this I used the keyfader function. I created a walkcycle with FK and then created a movieclip.
Damn! As I could have guessed, the keyfader really does what its supposed to do and my arms are not animated.:cry:

How can I alter my expressions to quickly resolve this problem without losing my FK_IK blender?

ljilekor
10-31-2003, 03:33 PM
I think this is really a bad one.
At first sight, there's no solution except baking and loosing all the comfort of the compose.
Damn...

I need a function like MotionClipResultFader() or something.
??? A plugin or a script maybe ???

Sometimes I'm askin myself if everybody encounters those problems or if it's just me.:annoyed:

lmilton
10-31-2003, 11:26 PM
Hi ljilekor,
you do seem to be having considerably more problems than most, but I suspect that this simply due to an unfamiliarity with the system, nothing more.

You should use the processing order options on the Command mode variables and/or on Compose mode tracks.

In Command this will be the second column in the variables list. In Compose this will be the fourth colomn on the tracks in the Tracks list.

Without seeing your scene, it's impossible for me to make a good recomendation for your settings. A good rule of thumb when using expressions on a charater that has clips applied, is to first determine what order you'd like these elements to compute.

I believe that the manual includes good info on processing order, but if you run into problems, please post a scene so that more users can provide assistance.

BTW, I took a look at the last scene you provided, but am at a loss as to what you're actually trying to accomplish. You don't actually have a complete walk in your clip. And if you were trying to just apply the motion from one leg to the other, it's probably a good idea to put each leg in its own group. It looks like you need to do one or the other.

I hope this was helpful...

-lyle

ljilekor
11-03-2003, 11:59 AM
I have no problems understanding the process order. The problem is that the keyfader function overrides everything.

Let's recap.

I need yo have FK_IK blending for my character. When I animate a walkcycle, I prefer to animate the arms in FK. I might need the IK later on (eg. to pick up an object, ...).

I'd like to use the composer (of course).

In order to make the FK_IK blender work properly, the process order for the KeyFader expression is set to AFTER_IK. (logic)
The keyfader does exactly what it's supposed to do: Override everything (also the composer) and read out the keyed motion of the arms.
But I need to read out the animation generated by the composer.
Switching the processing order of the composertrack to BEFORE_IK or AFTER_MOTION has no effect since the keyfader overrides everything. It tells the arms to execute the keyed motion at the actual frame.

Very logic. But not what I need.

In my case keyfader function should execute the keyframes generated by the composer, not the actual keyframes at that time. An new fuction may be needed. (Keyfader worx properly and does what it says). One that fades to the keys generated by composer.

I know I keep repeating things but in this case I don't know how to animate with FK, using the composer and preserving the FK_IK blending functionality.

If you want to, I can send you a sample scene to demonstrate the problem.

lmilton
11-04-2003, 07:04 PM
Originally posted by ljilekor
I have no problems understanding the process order. The problem is that the keyfader function overrides everything.

Let's recap.

I need yo have FK_IK blending for my character. When I animate a walkcycle, I prefer to animate the arms in FK. I might need the IK later on (eg. to pick up an object, ...).

I'd like to use the composer (of course).

In order to make the FK_IK blender work properly, the process order for the KeyFader expression is set to AFTER_IK. (logic)
The keyfader does exactly what it's supposed to do: Override everything (also the composer) and read out the keyed motion of the arms.
But I need to read out the animation generated by the composer.
Switching the processing order of the composertrack to BEFORE_IK or AFTER_MOTION has no effect since the keyfader overrides everything. It tells the arms to execute the keyed motion at the actual frame.

Very logic. But not what I need.

In my case keyfader function should execute the keyframes generated by the composer, not the actual keyframes at that time. An new fuction may be needed. (Keyfader worx properly and does what it says). One that fades to the keys generated by composer.

I know I keep repeating things but in this case I don't know how to animate with FK, using the composer and preserving the FK_IK blending functionality.

If you want to, I can send you a sample scene to demonstrate the problem.

Yup, I'm going to need a scene.

BTW, when you post the mpj, there's no need to zip it; mpj files are already compressed.

-lyle

ps: I don't know if you do this already, but you can post to the pmGmessiah forum to get assistance, as well.

ljilekor
11-06-2003, 04:00 PM
There you go:buttrock:

lmilton
11-06-2003, 07:27 PM
The problem is that you included the Slider in the Group/Clip. In your scene, you're using this slider to control the IK->FK blend. The problem occurs because the corresponding element in the Clip overwrites the value of the slider (which was 0.0 when you created the Clip).

To fix this:
1. Go to Compose->Tracks
2. Expand the "_1" clipinstance in the Track list
3. Disable (click in first colum) the FK_____IK element.

Now when you change the sliders, everything will work fine.

Important notes: it's not wrong to include the sliders and entire rig in the Group and Clip. In fact, it's recommended that you create a "Master Group" per chacter. You just need to be aware of the fact that your controllers (e.g. sliders, etc.) wil be mixed, as well if you create Clips with those Master Groups. If this is not the desired result, you can bypass those elements as described above. Alternatively, you could create additional Groups (objects can reside in multiple Groups) that only contain the objects that represent direct keyframe animation (sans expression controllers); this would allow for great flexibility. Then you may want to create an additional Groups that contain *only* the controllers. This allows you to create Clips to easily & interactively transform the motion of those items.

Tip: you can repeat your walk cycle by right-dragging the upper right corner of the clipinstance in the track view.

Let me know if this is helpful...

-lyle

ljilekor
11-07-2003, 03:59 PM
AAAARRGGHH It ain't working. My arms do not swing

My arms are not animated in the mcp. They stay at their last keyed position (because of the keyfader expression). Its the arms that get keyfaded (my slider is only the messenger).

The problem is that the keys generated by the composer are not seen as the keys by the keyfader function. The function goes deeper and checks the keyframes in the graph (not those generated by the composer(where my arms are animated))

By disabeling the FK__IK slider I can still keyframe my slider = I can blend between IK & FK while the walkcycle is running. That's logic.

I need a function like fadeToKeyGeneratedByCompose().
While a synonym for the keyFader could be fadeToKeyInTheGrapheditor() (and do not give a fak about those generated by compose). The Keyfaderfunction overrides the composer.
Switching the processing order of the keyFader or disabeling the slider doesn't help.

Whoow :shrug:

But don't worry. I found another way to blend between FK__IK so I won't need the keyfader anymore.

lmilton
11-09-2003, 01:14 AM
Originally posted by ljilekor
AAAARRGGHH It ain't working. My arms do not swing

My arms are not animated in the mcp. They stay at their last keyed position (because of the keyfader expression). Its the arms that get keyfaded (my slider is only the messenger).

The problem is that the keys generated by the composer are not seen as the keys by the keyfader function. The function goes deeper and checks the keyframes in the graph (not those generated by the composer(where my arms are animated))

By disabeling the FK__IK slider I can still keyframe my slider = I can blend between IK & FK while the walkcycle is running. That's logic.

I need a function like fadeToKeyGeneratedByCompose().
While a synonym for the keyFader could be fadeToKeyInTheGrapheditor() (and do not give a fak about those generated by compose). The Keyfaderfunction overrides the composer.
Switching the processing order of the keyFader or disabeling the slider doesn't help.

Whoow :shrug:

But don't worry. I found another way to blend between FK__IK so I won't need the keyfader anymore.

I think you may have misunderstood something, then. Or I'm misunderstanding your intent.

I tried it in the scene that you sent me, and it worked fine. All I did was disable the FK__IK slider in the ClipInstance (not the Clip), and I was able to control the blending with the slider.

I'll modify the scene and send it to you.

-lyle

Panikos
11-09-2003, 02:06 PM
Very interesting !
Now I understand why Sliders must not belong in a group, cause the Composer change their values, which themselves have a significant role.

Thanks for the tip.
Reasonable ;)

ljilekor
11-18-2003, 12:35 PM
My intent is not to blend between IK and FK. This I understand perfectly.
My intent is to have my walkcycle loop correctly (WITH THE ARMS IN FK).

I have another way to blend (swap) between IK and FK. It doesn't use the keyFader() function. So everything worxxx fine now.

Julez4001
11-18-2003, 02:38 PM
This may be asine but can you baked the IK keys and then move em.

CGTalk Moderation
01-16-2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.