PDA

View Full Version : mia_material_x_passes Transparency problem


avak
07-12-2011, 05:01 PM
Hello, please find the attachments,

in the scene there is a glass tin material (mia_material_x_passes) and a blin material + a miss_fast_skin mat , the problem is the transparency just doesnt work and I searched alot to fix it but no result,

I appreciated if someone find a direct and quick solution , thanks

Sebastianf
07-13-2011, 01:26 AM
Great a plane and put it behind your glass objects. Turn off primary visibilty, casts shadows and visible in reflections in the shape node. Put a 'Use Background' shader on it and turn 'off' reflectivity and put spec to black that should work.

edit: sorry i didnt look at your pic this is if you want the transparency to show up in the alpha. Maybe check if your object that isnt showing up has visible in refractions under Render Stats on the shape node of the object.

Kakkoii
07-13-2011, 01:51 AM
edit: sorry i didnt look at your pic this is if you want the transparency to show up in the alpha. Maybe check if your object that isnt showing up has visible in refractions under Render Stats on the shape node of the object.

Yeah, that's exactly his problem, took a look. It's also not set to be visible in reflections either.

To further clarify for him:
Select your Object, go to the "polySphere1Shape" tab in your Attribute Editor, and scroll down to "Render Stats". Turn on Visible in Refractions and Reflections.

Sebastianf
07-13-2011, 02:33 AM
Thanks Kakkoii (http://forums.cgsociety.org/member.php?u=382833) i didnt get a chance to open the file.

avak
07-15-2011, 05:33 AM
Hey thanks for your reply, actuality I imported this sphere (right one) from zbrush while I was testing , the format was obj.
I just did some other test and yeah all meshes that are importing by a obj format then their (visible in reflection and refraction) becomes automatically off . should be a bug

InfernalDarkness
07-15-2011, 03:37 PM
This is not a bug; this is how Maya has behaved with the .obj file format since the dawn of time. I believe at some point it had to do with backwards compatibility, from Maya 4.0 or something. But it's not strange that any .obj you import is set this way. Just make a quick shelf script to set selected objects to turn both on, or if you have tons of objects (like I do every day) you can just go into the Attribute Spreadsheet, Render tab, and change them all at once.

Sure it's totally stupid that Maya behaves this way, but it's always been like that.

avak
07-17-2011, 05:13 AM
Good to know about all these,
ok so I need a fast command to speed up this processes.
suppose we selected few objects and run a mel command that mel should do:
1- should access to their shapes node and put them in an array
2- one by one mel should read each shapenode in that array and set it's refraction and reflection attributes 1.

here is what I wrote and of course doesn't work! since I am not a programer need your help to correct this:

$objs =`ls -sl`; for ($obj in $objs)

{

string $shapeArr[] = `listRelatives -shape $obj` ;

string $shapeNode = $shapeArr[0] ;

setAttr "$shapeNode.visibleInRefractions" 1;
setAttr "$shapeNode.visibleInRelections" 1;


};


thanks

CGTalk Moderation
07-17-2011, 05:13 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.