PDA

View Full Version : Mysterious Curves


James-Arlyle
05-25-2011, 09:50 PM
I'm currently adding a muscle system on top of a rig I built using TSM2 and I came across an odd issue. Everything was working out fine until one day I opened my scene to see this:

http://i1231.photobucket.com/albums/ee518/jrstrong/Broken%20Rig/Illustration_BrokenRig.jpg
My character's upper body imploded upon itself.

I thought that something I'd done with the muscle system had destroyed the rig, but after digging around I found out that the problem was really some stray animation curves on the seventh spine joint that were causing divisions by zero:
http://i1231.photobucket.com/albums/ee518/jrstrong/Broken%20Rig/Illustration_ProblemCurves.jpg

At first I thought that I must have accidentally keyed the spine joint while testing out the rig. But then I noticed that there were only curves for a subset of the spine joint's keyable attributes: only ScaleX, ScaleY, Visibility, and the three translation channels. Additionally, when I went to look at the curves I discovered that they were completely empty!

http://i1231.photobucket.com/albums/ee518/jrstrong/Broken%20Rig/Illustration_EmptyCurves.jpg

Anyway, after deleting the curves everything popped back to normal.

The thing that's really thrown me for a loop though, is how these empty curves came about. I've tried to recreate the problem but I haven't been able to find a way of making an empty animation curve accidentally.

Does anyone out there know how this could have happened?

Thanks.

CGTalk Moderation
05-25-2011, 09:50 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.