PDA

View Full Version : spine controls get streched - help need


catty
05-14-2011, 06:51 AM
hi ....here i'm making a rig for a frog character ........ i'm almost done the rig but when i roate my spine controls they tempt to get stretched ...... any advice or help would be much appreciated ....... i attached a video sample and a my project 3d max file .......thanx a lot


video (http://fs09n1.sendspace.com/dl/922944ccc59c04916a19e21349254c07/4dce1715305acfee/glivwj/Untitled.mp4)

project file (http://fs10n5.sendspace.com/dl/84644e9d737a853fcfd7f69f057ff128/4dce18245844429e/cbdtnl/spine%20control%20issue.max)

MaxNorderfeldt
05-15-2011, 10:56 AM
Hi, I was going to look at your video but that site gave me a headache(and a feeling that my computer would get a virus. :P)

I recommend that you upload videos to youtube or vimeo, and files to dropbox(www.dropbox.com) It makes it easier for us to see the files that you took the time to create for us. :)

catty
05-15-2011, 04:21 PM
Hi, I was going to look at your video but that site gave me a headache(and a feeling that my computer would get a virus. :P)

I recommend that you upload videos to youtube or vimeo, and files to dropbox(www.dropbox.com) It makes it easier for us to see the files that you took the time to create for us. :)
hi .....never mind it doesn't contain any virus :) i tried youtube but due to heavy traffic uploading tempted to get failed ........ anyway here i uploaded it to hotfile ... if u can take a look i'll be really glad .........thanx

video (http://hotfile.com/dl/117906503/02ebdeb/rig_controler_stretch_issue__project_file.rar.html)

martinez
05-15-2011, 11:57 PM
ravi,

The problem you are having is called shearing. It's caused by objects in a hierarchy that have non-uniform scale applied. When rigging never use the scale tool at the object level. Never.

If a control object isn't the correct size, go into sub-object mode, select all the vertices and scale from there. But never scale at the object level. If a bone isn't the correct length use Bone Edit Mode to adjust the length.

In your scene right click on the scale tool and select the hip controller. Notice the scale value is something like 68,63,142. The controllers for the spine also have non-uniform scale. There's really only two methods to fix this. Unlink/unrig everything and reset-xforms, then re-rig. OR, preferably, rebuild all your bones and controllers without using the scale tool, and only use your current skeleton as a guide.

I also noticed that "shoulder_R" and "thight_R" have negative scale applied. I think you probably created them with the Mirror Tool on the main toolbar. This isn't obvious, but that Mirror Tool is the devil. The reason it's evil is because it just negative scales objects in order to mirror them. So effectively using the Mirror Tool is like using the scale tool.

Instead, use the Mirror button in the Bone Tools floater. In the Main Menu go to Animation > Bone Tools. You'll see the mirror button there. The difference is that the Bone Tools will re-create the mirrored bones and not just negative scale them.

I'm very sorry, but there is no fast fix for this problem. Just chalk this up to a learning experience, and promise you will never scale anything ever again.

catty
05-16-2011, 02:44 AM
ravi,

The problem you are having is called shearing. It's caused by objects in a hierarchy that have non-uniform scale applied. When rigging never use the scale tool at the object level. Never.

If a control object isn't the correct size, go into sub-object mode, select all the vertices and scale from there. But never scale at the object level. If a bone isn't the correct length use Bone Edit Mode to adjust the length.

In your scene right click on the scale tool and select the hip controller. Notice the scale value is something like 68,63,142. The controllers for the spine also have non-uniform scale. There's really only two methods to fix this. Unlink/unrig everything and reset-xforms, then re-rig. OR, preferably, rebuild all your bones and controllers without using the scale tool, and only use your current skeleton as a guide.

I also noticed that "shoulder_R" and "thight_R" have negative scale applied. I think you probably created them with the Mirror Tool on the main toolbar. This isn't obvious, but that Mirror Tool is the devil. The reason it's evil is because it just negative scales objects in order to mirror them. So effectively using the Mirror Tool is like using the scale tool.

Instead, use the Mirror button in the Bone Tools floater. In the Main Menu go to Animation > Bone Tools. You'll see the mirror button there. The difference is that the Bone Tools will re-create the mirrored bones and not just negative scale them.

I'm very sorry, but there is no fast fix for this problem. Just chalk this up to a learning experience, and promise you will never scale anything ever again.
ahh thanx a lot friend ......now it's clear :) yeah seems like no fast fix but i'll recreate the rig that's the best option :) now i have much more practice so will create it again :) thanx again for the tips ....... will update if any case i'm stuck :bowdown:

CGTalk Moderation
05-16-2011, 02:44 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.