PDA

View Full Version : Portal light shadow flickering!!!


lipuster
05-09-2011, 08:15 PM
Hi,
This is totally killing me since the last four days.
If you look at the girls arms and legs , youll notice the shadow dancing. This happens in ecery frame of my animation and makes it look awefully ugly.

The animation is a simple camera move with nothing else moving.

I am using maya 2010 with menatl ray.
I have tried final gather with rebuild on, off, and with rebuild freeze (making a final gather map from every 10th frame and using that). Ive increased my fg accuracy , point density and interpolation to 200,2,50 (in all my other scenes with similar scale and setups i use values of 100, 1, 40 with no flickering). Still, the flicker remians in all the cases.

More info: sampling at 0,2 with a gauss filter.Raytrace reflections 2, refractions 2, max trace depth 4. final gather optimmized for animation.All materials are mia. The materials on the offending arms and legs have their glossy samples upped to 16 (no flickering in other scenes where i use 8).

So after all these tests, im assuming its the portal light im using here that's causing the problem. Coz ive had no flickering in similar scenes with lower settings but the difference was i was using physical sun nd sky but here ive area light with portal. However, ive increased my samples from 32,4 to 64,4 and still same shadow dancing problem.


Please help. So many permutations at an hour per frame are killing me.

Thanks for your time.

lipuster
05-11-2011, 03:48 AM
After much hair pulling for the last two days, Ive come to the defnitive conclusion that the flickering is caused by the include indirect light option in the miss fast skin shader (ive used it plugged into a mia). Turn it off an absolutely no flicker. seems like many are having this problem and no solution in sight. Is this a bug???

So basically, i finally rendred a flicker free animation by turning off include indirect in miss. As an added plus, my scene renders faster.For stills, though, id still use it coz i really like the look it gives. If anyone knows of a solution to render flicker free misss with include indirect, please post.

Thanks and regards.

Kakkoii
05-11-2011, 03:56 AM
Have you tried doing the SSS into mia_material_x method? Using the mia_material for the top surface may allow you to get rid of the indirect light issue, while also allowing you to get an even better skin look.

http://forums.cgsociety.org/showthread.php?f=87&t=812111

lipuster
05-11-2011, 06:42 AM
Yes,

That's what ive done. But ive found that using the use indirect alongwith the mia x workflow allows for baetter result. But here, since I couldn't use that, i turned up the diffuse weight of my mia to .7, which i otherwise keep at .5. Still, its not the same thing.
(if it helps, I keep the diffuse and specularity of my misss at 0).
Thakns.

CGTalk Moderation
05-11-2011, 06:42 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.