PDA

View Full Version : Flipping pistons! Maya rigging question.


bellwether
03-18-2011, 04:08 PM
Flipping pistons! Maya rigging question. I have a piston rig. Basically two locators aim constrained at each other in the Z axis and the relevant geometry groups parented to them. On its own it works fine. Then I have a basic elbow joint chain - root_joint, middle_joint and tip_joint I want this joint train to drive the pistons so I parent constrain one locator to the root joint and the other to the tip joint. The middle joint is key driven. This also works fine. But now when I rotate the whole rig - the locators flip. I can rectify it a little by adjusting the rotation order of the locator in the attribute editor but then if I rotate the rig differently then the problem appears again. Am I missing something here?

uiron
03-18-2011, 05:03 PM
it's all about setting up your up vectors. read more about that in the manual, it's basics.

bellwether
03-18-2011, 10:38 PM
I read the manual but am still none the wiser. Just to be clear I will outline what I do and maybe someone can tell me where I am going wrong.
So, in the Front view I make a joint chain. Root, middle, and tip. Middle joint has set driven key to rotate in Z. The root joint is parent constrained to a nurbs circle which acts as the rig transform and rotate control object.
Then I make two locators and spread them apart. These are aim constrained to each other using the default settings. Then two elongated poly cubes. One parent constrained to each locator and thus I have a working piston.
To drive the piston the first locator is parent constrained (without rotate x,y,z as the aim constaints fill those channels) to the root joint and the second locator to the tip joint.
all works fine until I rotate the rig by the control object (nurbs circle). So where is my mistake?

nuternativ
03-19-2011, 02:10 AM
I tried all you mentioned, it works fine.
maybe, you check the aim vector option in aimConstraint option box or try removing the set driven key.

http://www.mediafire.com/?0jjpyu3118angy7 << see the file.

bellwether
03-19-2011, 06:05 AM
WOO HOO!

Thanks nuternativ. Yep it was the set driven key. The rig had some test animations applied before the pistons were attached.

Thanks for taking the time to do a test file too. Much appreciated.

CGTalk Moderation
03-19-2011, 06:05 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.