PDA

View Full Version : Mental Ray and Transparency Bug (Need Help)


rawb
03-16-2011, 06:51 PM
Hey guys,

I am having an issue in Mental Ray that I hope to recitify asap as I have to do the final render for tonight.

Basically, the scene is simple, I had to render a butterfly landing on a flower. No problem. I wanted a shadow cast on the main flower by another flower, but I didn't want the flower to render. So I turned off Primary Visibility in Render Stats for the objects. And it's working for the most part. However, when I render it in mental ray, any textures with transparency, such as the butterflies wings and the flowers petals.. the transparent parts show the flower in them (The one that isn't supposed to be visible in renders). If I turn off the visibility altogether you no longer see the reflection, but of course the shadow doesn't cast.

I really want to fix this as soon as possible. If anyone could help, that'd be great!

Reed5point0
03-16-2011, 06:56 PM
Also un-check "Visible in Reflections" in the area you unchecked "Primary Visibility"

rawb
03-16-2011, 07:00 PM
I'll try that right now. Thanks!

Reed5point0
03-16-2011, 07:05 PM
also Refractions just make sure it casts shadows...you probably don't want the hidden one to receive shadows either.

rawb
03-16-2011, 07:09 PM
Unfortunately that didn't work. I also turned off the reflections in the wings to see if that would work, but it didn't either.

Just to give a more clear idea of what I mean I am going to post the image, and also a wire render so you can see the placement.

Edit: I also turned off the other paremeters you suggested to no avail. Hrm, very frustrating

rawb
03-16-2011, 08:08 PM
I fiddled around with it some more, but I so far, other than turning it off entirely I can't get it to disappear. Does anyone have any other ideas?

Reed5point0
03-16-2011, 08:46 PM
Hard to tell really, did you apply the settings to each piece of geometry or a group?

rawb
03-16-2011, 10:16 PM
I went to the hypergraph and applied them all individually. :/ Blah.

kanooshka
03-17-2011, 02:33 AM
Hey Rob,

First off if you want to apply attributes to multiple objects you can select them and then use the Attribute Spread Sheet under Window->General Editors->Attribute Spread Sheet. This allows you to set multiple objects' attributes.

As far as the transparency issue, if you select the objects shape node then go under the mental ray section, try unchecking Visible in Transparency

-Dan

rawb
03-17-2011, 02:31 PM
Hello,

I will try that today! Thank you for the response! I'll let you know if it worked.

rawb
03-17-2011, 07:19 PM
Hello,

It worked! Thank you very much. Such an easy solution that I'd have never found on my own.

Thanks again,
Rob

CGTalk Moderation
03-17-2011, 07:19 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.