PDA

View Full Version : fire simulation problem


rochre26
03-14-2011, 06:58 PM
I'm having some problem with flickering in a fire simulation.

http://vimeo.com/21024818

My current suspicions are the animated fractal noise on the opacity/incndescence/color or maybe the auto resize.

I've attached my maya file if anyone would be kind enough to take a look at it.

Thanks.
Brendan Thompson

cowboy71
03-14-2011, 07:48 PM
Well just by peeking at your file, I noticed your values are way to high. For this type of smoke, I would only use around 80 to 40 for your density, cycling between the two. I would lower the solver quality to around 30 and substeps to 1. Wind is pretty strong as well. Sometimes you get flickering when raytracing is involved. I always try and light fluids with the built in lighting first, then try and take care of the rest in post. If someone else doesn't figure out the problem, I will try and mess with the file when I get some time today.

edit - oh and also, always use some Damp. I usually stick around .10. It really helps with the look and keeping your fluid stable.

rochre26
03-14-2011, 08:16 PM
Even if you don't find the time thanks a lot.

Duncan
03-14-2011, 09:33 PM
With auto resize make sure to turn off edge dropoff, as this effect is always relative to the container boundaries, which jump with with auto resize. Although I'm not sure if even a large edge dropoff could cause the huge problems with that scene. The texturing should be OK with auto resize, but be careful to avoid any of the gradient shading inputs, as these are also defined relative to the fluid boundaries, as with edge dropoff.

Duncan

Aikiman
03-14-2011, 09:47 PM
Id check your resolution and grid size settings first. These do not match so at the moment you will be getting elongated voxels. Choose a value to multiply your grid size with to get your resolution and carry that same value through all 3 axis.

I dont think that will help the flickering but this is pretty important.

Edit: I just realised I opened this in 2010 which doesnt support auto-resize, so my settings here will be wrong - sorry disregard what I said.

rochre26
03-15-2011, 06:41 PM
I turned the falloff off as per Duncan's suggestion. This seemed to help a little.

The biggest change I found was in the animation of my texture. I had set it to Grid then written some expressions for the time perameter and some for the origin perameter (I got these expressions from Wayne Hollingsworth's DVD). When I deleted the expressions everything worked much better with one exception. I cached my fluid and rendered. The final animation looked pretty good to my eyes but the hole thing froze for frames 62-70 then started where it left off. I cut out these frames in AE and it played flawlessly. I can't figure out why it froze. Frame 62 is where I started having problems the first time round.

Should I have left the expressions in and changed the texture to Fixed?

stooch
03-15-2011, 08:28 PM
i dont think you cached your fluid. im looking at the fluid cache node and it doesnt look right.

also, when using auto resize, make your fluid box just big enough to encompass your emitter, right now you have a huge fluid box, which means that auto resize has to drastically shrink your box at first, this is bad and slow (and probably does some funky stuff to your fluid during that dramatic scaledown). there isnt anything out of the ordinary with any of your settings otherwise.

I see that you are using expressions with your fluid texture noise, kill those for now.

Duncan
03-16-2011, 12:20 AM
The scale down of the fluid at the start frame should not cause problems.

However don't use the dynamic grid texture coordinate method with auto resize. The problem is that the new grid voxels in expanding regions get initialized to a uv of zero, which will obviously cause problems for your texturing. There is an outstanding bug to initialize these regions instead by extrapolating from the old grid boundaries, but it is not a simple problem.

Your freezing problem is strange. Perhaps your expressions caused an evaluation problem with the fluid. Or perhaps you had a partial cache on your fluid that was still attached.

Duncan

tokanohanna
03-16-2011, 02:26 AM
I'm having some problem with flickering in a fire simulation.

http://vimeo.com/21024818

My current suspicions are the animated fractal noise on the opacity/incndescence/color or maybe the auto resize.

I've attached my maya file if anyone would be kind enough to take a look at it.

Thanks.
Brendan Thompson

Hey Brendan,

Looking good so far. Like Duncan said, I would turn off your edge drop-off in your shading tab. I would also turn off your auto -resize threshold. That will hurt your sim, causing noticeable flickering. You will notice a value of 0, your container will fight but successfully create enough space for your voxels so they wont make contact with your grid. I noticed your Boundary Y is set to none. I would change that to -Y since you are not utilizing the " Re-size closed boundary" feature in the Auto-Resize section. Also disable texturing your opacity while using the expressions. Unless that is the look you are going for. I used those to drive my incandescence.
Adding to Duncan's last post, dynamic grid texturing is not so hot. You may also want to try using fixed instead of grid. Grid will cause your texture values to move with your density. Using the fixed feature...you force your texture to be still, appearing fixed in space, then you can move them along a particular coordinate with expressions. This gives you more control, if tweaked you can get nice results. Lastly like Cowboy said....your density values are through the roof. I would start with a value of 5 and drive it with good amounts of heat and fuel. Good look.....looking forward to seeing your results.

Wayne

rochre26
03-17-2011, 09:38 PM
Fantastic guys. Thanks for all the suggestions. I'm sure I'll be back for more.

Wayne - Thanks for the help. I've got your Gnomon DVD but guess I wasn't paying close enough attention. It's helped me a lot so far.

Saw the Air Force piece you did for Psyop on TV. Looked good.

Duncan - special thanks to you as well. This stuffs hard.

CGTalk Moderation
03-17-2011, 09:38 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.