PDA

View Full Version : Mray/ "-fb_virtual cache" parameter for huge print res


Libor
02-28-2011, 09:53 AM
Hi,

I need to render huge picture (cca 10k high and 7K wide) and mray do not want to render it....so I guess its limit of virtual framebuffer size/memory...also tried in batch render

I went through the mr manual and found an interesting rendering parameter when using mray from command line.

mr -fb_virtual (on/off/cache) ...the default is on which store whole fbuffer into physical memory and the cache option should write every render bucket/buffer on hard drive so no extra memory needed > as manual says it should be used for extra large framebuffers in terms of pixel counts...

However whenever I try to use it in cmdline it doesnt recognize this parameter so I d like to know if anyone used it before.

Maybe its only in mray standalone but this info was in the mray for maya docs so I guess it should work in Maya batch command!

Im running Maya 2011 64bit, Win7 (all maya spacks installed)

Thanks for any info!
L.

Puppet|
02-28-2011, 11:34 AM
For rendering large images first of all you should disable "Export Post Effects" in Render Globals, otherwise Maya will crash after 100%.

You may switch buffer mode via mel command:
setAttr mentalrayGlobals.frameBufferMode 2;
0 = off, 1 = on, 2 = cache

Libor
02-28-2011, 01:35 PM
Hi! Thanks for your input Pavel!

Well Im not sure if I used it correctly I put the script into pre render MEL scripts in RenderGlobals (I have tried different types (prerender mel, prerender layer, prerender frame) but every time my batch render crashed :(

here is a bit of process output message (just before the crash occurs - it doesnt start to render at all)...must be something with the size of fbuffer cos when I submit render at 80 percent reduced size the render goes normal and finnish....

here is a bit of a progress msg:

"RCI 0.2 progr: begin intersection preprocessing
RCI 0.2 info : using scanline for eye rays
RCI 0.2 info : using BSP2 for secondary rays
RCI 0.2 progr: end intersection preprocessing
RCI 0.2 info : wallclock 0:00:00.00 for intersection prep.
RCI 0.2 info : allocated 2152 MB, max resident 2152 MB
RCLM 0.2 progr: lightmap vertex run, shader 0x73c: misss_fast_lmap_maya1 on instance 23:0
PHEN 0.2 progr: misss_lightmap_write_init: Got shader init
PHEN 0.2 progr: misss_lightmap_write_init: Got instance init 309441048
PHEN 0.2 progr: misss_lightmap_create: starts w. tags 1757 and 0
RCLM 0.6 progr: lightmap vertex run, shader 0x73c: misss_fast_lmap_maya1 on instance 13:0
RCLM 0.8 progr: lightmap vertex run, shader 0x73c: misss_fast_lmap_maya1 on instance 10:0
Result: P:/O2_1104/3D/Maya_O2_2011/scenes/_render/previews/lenka_tex_03.ma
Fatal Error. Attempting to save in C:/DOCUME~1/smedge/LOCALS~1/Temp/smedge.20110228.1426.ma
--- Attaching to process stderr stream ---
// Maya exited with status 1"

Any idea?

Thanks again for your kind response!
L.

Bitter
02-28-2011, 05:53 PM
You can also change your framebuffer cache mechanism under the miDefaultOptions. (You can select this in the select by name box by typing: miD*) Under the mentalrayGlobals look for the Extra Attributes rollout at the bottom. You will find Frame Buffer Mode. Use this.

I am not sure that will conflict with what Pavel mentioned.

It's also possible your lightmap is huge. It's based on screen resolution and the container itself for a lightmap may have an internal limit. I am not sure of that but might be worth investigating.

Almost forgot: turn off Scanline (for everything) Select raytrace. This will help your memory consumption.

Eshta
02-28-2011, 08:28 PM
I'm pretty sure there is a cap for the framebuffer of 2 GB
why not split the image with -reg flag

Libor
03-04-2011, 11:51 PM
great tips Bitter!! I can think of the lightmap which is res dependend ...Im using misss_fast shader in there so the default lightmap size is expression driven probably causing a lot of memory consumption....also the scanline tip is interesting!!

Ill give it a try tommorrow (I need to finnish about 3 10k renders during weekend!) I hope much that it will help.

Thanks again for these tips!

L.

Libor
03-05-2011, 06:31 PM
Great tips which also worked!! Thanks much Bitter I owe you a beer :beer:

Short info: my render was 9933x7016px which caused expression driven misss lightmap explode to 14500px height in full 32bit float.....read huge eating of ram

also switching to pure raytrace mode helped.

Great!

L.

CGTalk Moderation
03-05-2011, 06:31 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.