PDA

View Full Version : Spline IK at tiny scale


theflash
02-25-2011, 12:33 PM
Hi,

I am doing a simplest spline IK setup, but at a very tiny scale (my joint radius viewed at size 1 have radius of 0.01). And when I move the CVs I can see joints jump a little bit off from the spline curve. Have anybody seen this problem before?

update:
If I create the spline IK at a normal scale and then scale everything down by grouping it then it all works fine. So I guess the problem is when you create joints in a very small scaled space then it creates the problem.

tonytouch
02-26-2011, 10:54 AM
i also recognized this flipping , with a simple IK_chain 3yrs ago .

in my case the "micro-scale" of the entire scene was set to 0.01 = 1 meter (maybe it was even 0.001 = 1 meter , i dont remember , but the rigs were "really small" ) . i had a rat-character , which was even smaller than the human-characters . i did not have any problems in the human-rigs , but for some of the rat-poses i found out this flipping to be occuring --- first i did not know 'waz up' --- but then , my conclusion was the same as yours ... the flipping comes from the " scale" and "accuracy" of the IK_calculation in "micro-space" .

@edit:
i am a maya-user ( this might be relevant )

theflash
02-27-2011, 01:25 PM
I think there is a problem for IK spline solver in Maya when scale is very small.

I am in centimeter measurement and if I scale my IK spline rig down to 0.03 then the solver does not move joints for small movements, my controls have to move enough distance for joints to follow. So I am guessing that this is probably some kind of floating point error.

CGTalk Moderation
02-27-2011, 01:25 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.