PDA

View Full Version : Problem with fluid velocities and collisions


BillyTheKid123
02-11-2011, 08:33 AM
I'm using fluids to drive my particles and need a collision surface to collide with the fluid (the ground). This is in addition to the nRigid collision of the nParticles. After running the sim for a bit, the velocity vectors get out of control. Anyone know why?

ZeitG
02-11-2011, 09:49 AM
"This is in addition to the nRigid collision of the nParticles." - is this necessary?

try to increase "tesselation factor" at geoConnector of collision surface.
in Fluid try set to "off" forward advection, if it is.
And may be your simulation is fast, play with "solver quality" "substeps" in dynamic simulation, and "evalutate every" in Fluid Cashe Option.

BillyTheKid123
02-11-2011, 07:04 PM
it is necessary because im trying to get the effect of ash being pushed away from landing engines of a ship. if the fluids don't collide with anything, I just get random swirling with little control. I have already tried increasing tesselation and tried a substep of 5 in the fluid, and I have never turned on forward advection.

The fluids velocities initially react correctly and push away from the collision impact point, but then begin rushing towards the impact point with ever increasing magnitude. The fluid is set to no boundarys on any sides and only veloctiy is set to dynamic grid. I do have a little damp on the fluid as well

Phlok
02-11-2011, 07:06 PM
Make sure your fluid has some dissipation, otherwise your container might fill up resulting in extreme forces inside the fluid and this will make the fluid explode.

Forward advection might help in some cases when using High Detail Solve.

When both these recommendations are useless, try increaing the substeps.

BillyTheKid123
02-11-2011, 08:34 PM
How do I use dissipation when the only thing being emitted into the fluid is velocity from a vol axis cyl? I put a drag field cube under the ground instead of the colliding plane and that has yielded somewhat ok results. I have noticed that the fluid box keeps enabling density on me even though there is no actual fluid emitter connected... strange.

I will try out forward advection but I thought that only had an effect if density and heat are used in conjunction with high detail solve?

eaclou
02-11-2011, 08:57 PM
Add some damping to the fluid container, and let the volume axis field "build-up" velocity for a few frames before rendering, so that it can find its equilibrium with the damping value, and stay more consistent.

velocity from fields starts at zero and grows each frame unless you have some damping.

Turn on velocity arrow draw to see what's going on in your fluid.

ZeitG
02-11-2011, 08:57 PM
you have density set to dynamic grid, for what? "there is no actual fluid emitter connected..." "strange"
try to set "preferences" -> "time slider" -> "playback by" = 0.5

hope this help

Derek Wolfe
02-11-2011, 09:00 PM
What you are describing sounds like the effect of velocities getting too high relative to the voxel size, and timestep. Generally damping and oversampling will help. You have tried both, but you might need to go higher with either, or both of these settings.

CGTalk Moderation
02-11-2011, 09:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.