PDA

View Full Version : Fluids and VolumeCaustics


MrMint
02-01-2011, 09:27 PM
Has anybody managed to get VolumeCaustics to run with fluids?
The only information I found about that issue was....
http://forums.cgsociety.org/showpost.php?p=1314336&postcount=35

(here the important paragraph)
5. A weird thing though is that the Fluid Contaner has a Mental Ray section for FG, GI and Caustic setting overrides, which you would think indicates that GI and Caustics should work on them. I played around with those settings and they did nothing, not even for FG.

I can see the photons with the mapVisualizer, so far so gut. But it seems that the photons dont illuminate the volume.

AutodeskLab
02-04-2011, 02:09 AM
i would enable gi/caustics settings in your render node options.generating and receiving : on.

MrMint
02-07-2011, 08:06 PM
Thank you for your input.
I think anything necessary is enabled because if I just hide the fluid box and unhide the partiVolume-box I get my volume caustics. I guess if it is possible it would be my shader-setup
that is not setup correctly.

Interesting that I dont need any photon-collector to get my photons (Maya2009 btw.) displayed.
The shader-connection on the left side of the picture is from the fluid itself.
The MapVisualizer displays the photons even if I have just the partiVolume_photon connected but
nothing inside the volume gets illuminated.

http://img534.imageshack.us/img534/7758/causticfluids2.jpg (http://img534.imageshack.us/i/causticfluids2.jpg/)

doctorcillo
02-08-2011, 09:39 AM
Are Autovolume and VolumeShaders checkboxes activated in your Render Settings?
Make sure they are and let us know!

RenderSettings -> Features -> ExtraFeatures -> AutoVolume

Hope that helps.

EDITED:

Check that PhotonAutoVolume is checked also in RenderSettings -> Features -> ExtraFeatures ->

MrMint
02-08-2011, 10:20 AM
Yes they are. I guess I wouldnt get any VolumeCaustics from the partiVolume-box if they were not enabled.
Sorry for having skipped that information.

CGTalk Moderation
02-08-2011, 10:20 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.