PDA

View Full Version : Fast Skin Shader + Normal Maps = Fail


butterbr0t
01-18-2011, 10:10 AM
Hey there,

I am trying to add some scars around the eye to a character using normal maps. This works with a a standard shader in Max, but it looks very wrong when used in conjunction with the mental ray SSS Fast Skin Shader. The Normal Map is inside a Normal Bump Map, which I put into the Bump Slot of the SSS Shader. The whole effect of the shader gets destroyed and the shadows look facetted. You can see it here (Left is Viewport in Mudbox, Middle is Skin Shader without NM, Right is Skin with NM):
http://img98.imageshack.us/f/nmproblem.jpg/
This is the Normal Map:
http://img651.imageshack.us/f/45152482.jpg/
And these are the UVs for the Head and Hair:
http://img109.imageshack.us/f/uvsf.jpg/

I am using 3ds Max and Mudbox 2011 x64. The scene is lit with a daylight system (mr sun & sky).
Any ideas what I can do? I would really appreciate any help :wavey:

Regards

musashidan
01-20-2011, 10:41 AM
Did you turn off filtering on the NM? Did you uncheck 'screen compositing of layers' on the shader?

butterbr0t
01-20-2011, 12:16 PM
Hey,

I did not turn off filtering so far. If you mean the option inside the bitmap (Pyramidal, Summed, None), then this did not make any difference for me. Screen compositing is off.

Right now it seems that not the shader is the source for the problem, but the daylight system and the mr photographic exposure control. The NM works with the skin shader when I do not use the daylight system and exposure. Unfortunately, the skin shader flickers quite a bit in conjunction with fg+gi in animation. So the combination of skin + NM + Daylight system doesnt work as I expected...damn

musashidan
01-21-2011, 12:25 AM
Weird?? I just set up a test scene here(2010) default MR. Default MR sun/sky. Fast Skin+ shader with normal map. No such problems. Have you tried starting from scratch with a stripped down scene? Sometimes this is the best way to troubleshoot a particular problem.

butterbr0t
01-21-2011, 12:28 PM
Hey,
thanks for your answers. I also tried some more things in new scenes, and it seems that I generally get problems when using Normal Maps with Mental Ray, no matter what light source is used. Maybe its a 2011 thing, or something is messed up with my installation of max, I dont know... so much time wasted for that stuff already that I consider not using any Normal Maps at all, maybe not even the skin shader cause of its flickering. On a side note, I tried pushing the Output value of the Normal Map (cause I thought that would help compensate for the mr photo exposure), and it gave me better results with values of about 2.0 (see attached image). Higher values would cause color changes and general noise in the shader.
Regards

musashidan
01-21-2011, 02:17 PM
One other very important thing I forgot to mention: don't forget to set the normal map's gamma to 1. this will obviously depend on how you have your LWF set up.

butterbr0t
01-22-2011, 09:14 AM
I think that could be it! I am using a general Gamma&LUT of 2,2 because of the daylight system. When I put my normal map into a Gamma&Gain Map, leave the Gamma at 2,2 but uncheck "Reverse Gamma Correction" I get the result that you can see in the attached image. Seems to be what I was looking for! Thanks alot Daniel :D You have some great work btw, I especially love the Dwarf Hammerer :)
Regards

musashidan
01-22-2011, 12:22 PM
thanks for the compliment Christoph. Glad you got your result. Although you don't need to use the Gamma/Gain map. If you have your Gamma set up as 2.2 input/output, then whenever you import maps just use the 'override 1' option in the import dialogue for: .hdr maps, normal maps, any greyscale maps(bump/spec/displacement/etc) and leave it at 2.2 for colour maps.

CGTalk Moderation
01-22-2011, 12:22 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.