PDA

View Full Version : Maxscript commands that don't work as expected


sergo.pogosyan
01-11-2011, 07:59 AM
Hi,
I have a proposal - to create sticky page here that will contain things in maxscript that don't work as expected (or don't work at all). I believe nearly every maxscripter will find something to write on that page.
I think that kind of page would be very useful for everone who is working with maxscript.

First two things that definitely don't work: (At least for me. Show me that I'm wrong, please.)






crossing parameter has no effect in boxPickNode and in circlePickNode commands.


netrender parameter has no effect in render() command.
Thing that I could not make work and I think that it doesn't work at all:



#progress option in <netManager>.setCallback command. Don't know about other options, I think that they don't work either.

PEN
01-11-2011, 12:19 PM
The problem with a bread like that is people hat are not using commands correctly will be posting them as problems in max script.

I can see this being a useful thread.

sergo.pogosyan
01-11-2011, 02:18 PM
The problem with a bread like that is people hat are not using commands correctly will be posting them as problems in max script.

I can see this being a useful thread.

I agree with you Paul, I thought of that. But information like this is really helpful, and it is not always possible to find the source of problem.
Is it possible to create a wiki page here instead of the forum thread? I've tryed, but it seems that I have not enough permissions to edit wiki pages on cgtalk.

haavard
01-11-2011, 04:47 PM
Great thread, the threshold for posting potentially embarrassing problems is lowered ; )

The crossing feature works for me:

(
delete $*
viewport.ResetAllViews()
b = box()
centerpivot b
b.pos = [0,0,0]
format "crossing:true \t%\n" (boxPickNode (box2 [0,0] [gw.getWinSizeX()/2.0, gw.getWinSizeY()/2.0]) crossing:true) as string
format "crossing:false \t%\n" (boxPickNode (box2 [0,0] [gw.getWinSizeX()/2.0, gw.getWinSizeY()/2.0]) crossing:false) as string
)


but this don't work for me:

(
pp = Particle_Paint Spray_At_Type:1 Spray_At_Objects:#(box(), teapot())
print pp.Spray_At_Objects
)

The objects don't show up in the listbox, and you cant paint on them, but they are in the object list, i.e <Particle_Paint>.Spray_At_Objects. If I add them manually it works as normal and I can paint on them. If I add new objects - say like a sphere, and paint some particles on it - and print out pp.Spray_At_Objects again, the sphere is not listed, just the original box and teapot. So to me it looks like two separate node arrays

sergo.pogosyan
01-11-2011, 06:57 PM
Thank you havard, I've replied you by PM to keep this thread clean for discussing the process of creating wiki page.

It seems that wiki page would the best choice. People can discuss specific problems in separate forum threads and when the problem is proved as a bug it could be placed to the wiki page.

Insanto
01-12-2011, 07:37 AM
pastebitmap function in max 2009

CGTalk Moderation
01-12-2011, 07:37 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.