PDA

View Full Version : Frustration with Mia Material and lack of Wrapper


JamesCG
01-04-2011, 07:15 PM
Good morning all.

I've back to working with Softimage (2011) and I'm working on a project that is using the mia_x material. When I tried to output different Frame Buffers (Diffuse, Reflection, Irradiance) I noticed those buffers would only render black.

So it seems I need to use the Mia_Material_X multi-output material. All well and good but I can't seem to find any mia material wrapper to plug into. Am I missing something here? Is the mia material wrapper a 3rd party addon?

I've done some basic research but have been unable to find working links for the following 3rd party addons:

Frenchdogs mia_x RenderChannels Addon
http://frenchdog.wordpress.com/2008/10/25/mia_x-renderchannels-an-autodesk-compound/

or

Lard's Mia X Wrapper found here on XSIBase at
http://www.xsibase.com/netview_forum/index.php?board=12;action=display;threadid=43241

I've left messages for both authors to see if working links are present (I might be missing something obvious).

If anyone has any ideas on perhaps something obvious I'm missing or working links to those two addons I'd appreciate it.

~ JamesCG

Saturn
01-05-2011, 10:14 AM
use the mia_material multi output
plug the output that you want into a color frame buffer node, name the color frame buffer the way you want ( eg. refl_raw )
Then plug all color frame buffer node to a color share node and plug this one into surface.

That is pretty straight forward.

If you could not do that yourself have a look to the autodesk area.
I have set a counpound there and uploaded it when we had the softimage communauty web page but this should be transfered to the area.

CGTalk Moderation
01-05-2011, 10:14 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.