PDA

View Full Version : Maya Spline Rig Problem


eYadNesS
12-30-2010, 08:47 PM
Hi,

I'm having a problem in setting up a twist control for my spine rig, the problem is that when i rotate my chest control, the locators of the twist control are moving up, because of the joint Y orientation is changing.
That's because my spline curve is an "arc" shape, if its "straight" I don't have this problem!

Any idea of how i can fix this?
I just want to rotate my chest control or hips control and keep my joints Y rotation value 0.

AutodeskLab
12-31-2010, 02:07 AM
i would maybe try to set a key on your y value.

eYadNesS
12-31-2010, 06:37 AM
i would maybe try to set a key on your y value.

I set a key on the Y values, and its still the same. And I also tried to lock them, and i still have the same problem..

My locators are grouped, and the groups pivot points are in the spine joints, and the groups are childs for spine joints. Because I want the locators to rotate around the body, and make my bond joint to aim to them to get the twist function.

eYadNesS
12-31-2010, 01:54 PM
thank you, i found a solution :)

I just wrote an expression to control my rotation values, without grouping or constrains.
Now i can control the twist and my spine joints are aimed to the locators. Even I can animate the locators separate.

AutodeskLab
01-01-2011, 09:04 PM
you are welcome eYadNesS. very good solution.
happy new year.

CGTalk Moderation
01-01-2011, 09:04 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.