PDA

View Full Version : MR mia_material Refraction problem


mjay85
12-24-2010, 11:56 PM
Hey all.

First, happy holidays!

On to the CG question. I am working on a couple different projects (one being that lemon shading project I posted before), and am using mental ray / mia material for rendering. I have noticed something strange happening with refraction. In some of my scenes, when I try and render an object with a 100% transparent mia shader applied to it, no transparency renders. Reflection works perfectly however.

I did several tests for this. First, as the most obvious thing, I made sure my raytracing tracing settings were set properly. Yes, they were. To verify it wasn't something involved with the render settings, I created a new scene with a cube and a sphere. I created a new mia material with 100% transparency and applied it to the sphere. I set the render settings to "Preview" under mental ray. It rendered all transparencies properly. So, I imported a character from another scene that I was having issues with, and instantly the refraction stopped working. I double checked my render settings, and everything was the same. Here is the result. http://michaeleurek.files.wordpress.com/2010/12/broken_refraction.jpg The sphere in the front has a 100% transparent mia material applied. There is another lemon right behind it.

I have been trying everything to figure this out. I'm stuck now. If anyone has any ideas or suggestions, I greatly appreciate it! Thanks everyone!

- Michael

RasoulValli
12-27-2010, 09:22 AM
i have this problems too.
&
i use blinn material instead of mia or dielectric because of the problem

kanooshka
12-27-2010, 02:57 PM
It looks like the transparency is working fine in the image you posted. The transparency is warped because of refraction. Maybe you just need to decrease the index of refraction. Are you having issues because you can't see the lemon through the sphere?

mjay85
12-27-2010, 08:25 PM
Hey, thanks for the response guys.

Yes, the issue is not being able to see the lemons through the sphere. I set the IoR to 1.0 (which is almost the value of air right?) and thus there should be no refraction. I have two other images to illustrate the problem a little better. I used a plane with a checker node in the transparency value. The first image has a blinn while the second is using the mia material.

1. http://michaeleurek.files.wordpress.com/2010/12/blinn.jpg
2. http://michaeleurek.files.wordpress.com/2010/12/mia.jpg

As a side note, if I create a new scene with a similar setup. I have two spheres and a plane with a mia material in the foreground. I set the transparency with a checker, and the IOR to 1.0. The render settings are exactly the same as the lemon scene, but it works.

http://michaeleurek.files.wordpress.com/2010/12/mia02.jpg

I really can't figure it out. Its also not just the lemon scene, there are other files with this issue.

kanooshka
12-28-2010, 01:44 AM
Did you select the lemon's shape node and in it's render stats check "Visible in Refractions"?

-Edit- Sorry misread your post.

Are you using Maya? If so, feel free to send over the scene in an email, it's difficult to troubleshoot something like this. Hopefully I'd be able to figure it out pretty quickly.

mjay85
12-28-2010, 07:41 AM
Hey Dan,

That was it! You got it. For whatever reason, i was checking the attribute spreadsheet of the object with the refraction, rather than making sure the objects that should be affected by it were set up properly. I selected all the objects in the scene, opened the attribute spread sheet, and turned on "visible in refractions/reflections". I can't figure out why it was turned off, but yea, that was it!

RasoulValli, give that a try and see if it fixes your problems!

I really appreciate it. Sometimes when I get so into something, its hard to see the most obvious things. :beer:

- Michael

kanooshka
12-28-2010, 02:24 PM
Glad that worked!

Sometimes if you import objects from an FBX or OBJ file those Render Stat options won't be set up correctly.

CGTalk Moderation
12-28-2010, 02:24 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.