PDA

View Full Version : Light w/o visible Emitter (A&D selfillumination)


ereshkigal
12-17-2010, 11:34 AM
Hi folks,

I made this one with PFlow and A&D Selfillumination. It's a still from a tracking shot, both the camera and the glowing particles are moving.

http://julianquitsch.de/diplom/_img/maria05_t.jpg (http://julianquitsch.de/diplom/_img/maria05.jpg)

This is quite what I wanted to achieve. For another shot I need the same scene with identical lighting, but without the very blobs visible! Everything I tried resulted in the light itself to disappear too.

I admit this could get more of a PFlow question, since I could achieve the effect by replacing the blobs by omnis - however it seems I can't define omins as particles...

JeffPatton
12-17-2010, 01:54 PM
It would probably be easier to do with lights instead of self-illuminated geometry but as you mentioned that's not supported by default. Thankfully there are scripts available that allow you to use lights with PFlow, like this: http://www.scriptspot.com/bobo/mxs5/pflow/pflow__MovingObjects.htm

ereshkigal
12-17-2010, 03:27 PM
Thanks for the reply, Jeff!

This really seems to solve my problem!

How about render times? I am thinking about rebuilding the whole scene above, replacing the self illumination with regular mr_omnis if it's worth the time saving.

JeffPatton
12-17-2010, 04:02 PM
Using lights may render slower than the self-illuminated geometry (especially if they are area lights).

You know, now that I think about it I wonder if you could just make the self-illuminated geometry hidden from the camera (object properties, visible to camera = no)? I assume you already tried that and it didn't work? If so then you may be able to use a raytype switcher to keep the FG contribution of that material while hiding it from the eye rays.

ereshkigal
12-18-2010, 03:04 PM
Got it!

Setting the properties of the particle geometry object and the particle instances in the viewport/scene even to 'not renderable' did not change the rendering at all.

Only changing the event's object properties in Particle View to 'not visible to camera' did bring the desired effect!

I am quite happy that it was so easy in the end, since the other solutions seemed quite complicated for the noob that I am.

Thanks again!

CGTalk Moderation
12-18-2010, 03:04 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.