PDA

View Full Version : problems with PyMel - pymelScrollFieldReporter.py


onehope
12-14-2010, 11:00 AM
Well, my problem is that after install PyMel succesfully ( at least that's what I thought ) and place the "scriptEditorPanel.mel" file into "C:\Users......\maya\2010-x64\scripts" directory, and "pymelScrollFieldReporter.py" file into "C:\Program Files\Autodesk\Maya2010\bin\plug-ins" directory. a series of problems came up:

1.- the first problem is that pymelScrollFieldReporter.py plugin is loaded automatically even If I explicitly tick off the autoload property. It is, it always loads at maya startup ( maybe this is the right way to work , I don't know)

2.- now every time I open the script editor I get this message: "# Error: Invalid argument: #" and every time I close it this another one in the output window: "swig/python detected a memory leak of type 'MCallbackId *', no destructor found."

3.- when I open the script editor , the scroll on the History section appears on the top (the first line) instead of the bottom (last line).

4.-plus, sometimes, when I have the script editor opened the normal maya keyboard controls don't work ( w, e ,r ,q ,delete) is very weird because you can select the objects in the viewport with the mouse but to be able move them by pressing the keyboard shortcuts , you should close the script editor first. When this happen to me , I restart maya and normally it fixes the problem.....



Anyways, the scripts are working "good", it is: the script editor spits the commands in python but these "problems" are very annoying.....


I'm using maya 2010 x64 in windows 7 ultimate x64 and the pymel version is 1.0.2

Any idea of what's happenning?

Thanks in advance

D

CGTalk Moderation
12-14-2010, 11:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.