PDA

View Full Version : Maya Mentalray Portal Light Flickering Problems


mahe4art
11-22-2010, 10:58 AM
Hi There,

I been facing a flickering problem in maya mentalray.

Used all mental ray Shaders.
Maya Physical light.
Area Light with portal light shader.

FG and GI
Saved FG Maps and Gi Maps in every frame. Still its been flickering.

Render Time is 4min HD 720 size.

http://img89.imageshack.us/img89/8494/dd12.gif (http://img89.imageshack.us/i/dd12.gif/)

The still images were good but when i rendering sequence it getting flickers in every image.:confused:

Flickers near by all metals and shadows.:(

R&D stuff myself-:rolleyes:
I deleted the portal light its works prefect but not good quality.
I know some weird problems with Area lights but i have to use the Area light to save render time and to get nice render image quality.
I changed the Area light to direction but still its same flickering and good quality.
So i came to know that Area light shape creating some flickering in the scene.:rolleyes:


http://img100.imageshack.us/img100/8072/arealightshape1.jpg (http://img100.imageshack.us/i/arealightshape1.jpg/)

If i un tick that USE LIGHT SHAPE it wont Render at all and it makes the image very dark and it stops the portal light bouncing effect. No use
I just really try to render a sequence images with portal lights.


Please help me if any body know this kind of issues. Thanks very much for your help, and viewing this problem.:roll:

zmuh11
11-22-2010, 02:45 PM
I see less flickering and more noise. Perhaps turning up samples will help out?


Also you said you save an FG and GI map for every frame? Try just using 4 or 5 because if I'm right(and I may not be) but MR will smooth out the frames inbetween your saved maps so that might help with the flickering, and it would be an easy test because you already have them!

Those are my ideas, hope that helps.

Zach

Kornelius
11-22-2010, 04:53 PM
some tips to avoid flickering animations :
-increase FG accuracy (may result in slower render time)
-Final Gather mode "for animation"
-increase the FG filter
-try to add a "filler" point light (with specular emission disabled) with a low value and place it on the opposite side of the incident light direction.

I'm a noob, but I'll give them a try!

Kornelius
11-22-2010, 04:58 PM
I've forget to mention that once you have enabled the FG mode "for animation", you could tweak the min/max radius on your own.
The rule of thumb it's max radius of 9% of the total scene size and min radius of 9% of the max radius.

mahe4art
11-23-2010, 12:51 PM
Wow Thanks very much for you reply.

Zach Haugen
I think u r right, its all grainy noise flickering.
the problem was solved but render time took the roof.
I don't think spend too much of time on render, its not worthy for this kind of small scenes.
Here is the new Render image HD 720 25 min of render time. Very little grainy noise flickering problem

http://img833.imageshack.us/img833/8968/m12t.jpg (http://img833.imageshack.us/i/m12t.jpg/)


Here is old Render image with grainy noise flickers. 2k Res 35min render time. But this one has flickering problem.
http://img827.imageshack.us/img827/633/bedscenegreenc3acdc.jpg (http://img827.imageshack.us/i/bedscenegreenc3acdc.jpg/)

Any Suggestions, How to render in a less time. I have done some test of portal light its been coming very nice in other scene with out any noise, but i don't understand why this noise is generating in this scene. am using the same set values.

Thank you every one for viewing the problem.

CGTalk Moderation
11-23-2010, 12:51 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.