PDA

View Full Version : Particle Flow doesnt work after re-opening scene


JohnDoe22
11-16-2010, 11:36 AM
Hi, i just posted a new thread, but can't find it anywhere... think something went wrong, so here again:)

I'm using 3ds Max 2011 64bit with SP1 (Advantage Pack, with new Physx) and Particle Toolbox 1,2,3. I'm kinda new to PF, so i'll try to explain my problem.

I have two hollow shapes, each one is filled up with particles by it's own birth event.
EVENT: Birth, Physx World, Cache Disk, Position Object, Shape, Physx Shape, Spin, Material Static, Display, Physx Colission, Age Test.
Both birt events use the same Physx World driver. At frame 225 the age test sends both particle events to 1 new event.
EVENT: Shape, Physx Shape, Physx World, Material Static, Display, Physx Colission.
This event uses a new Physx World driver. In this event the Physx Collision fillshapes are removed, so that the particles fall to the ground.

So far so good, but every time i re-open my scene (after a save, a crash, whatever) and i try to render, Max crashes at frame 255 where event 3 kicks in. And i have to delete this event and rebuild it every time. This way it's impossible to render the whole scene because of system crashes, powerouts, rendertime, etc. :) I just want to perfect my settings and add a Disk Cache to the 3th event as well so i can render my scene in multiple parts, without any changes to the position of my particles every time i had to rebuild my 3th event.

So what am i doing wrong here?????
thx

PsychoSilence
11-16-2010, 01:24 PM
it would help if you could attach your scene file for debugging.

JohnDoe22
11-16-2010, 01:43 PM
it would help if you could attach your scene file for debugging.
I've send you the link via PM

PsychoSilence
11-16-2010, 03:11 PM
fixed sort of and replied :)

JohnDoe22
11-16-2010, 03:20 PM
Thanks a lot!! Unfortunatly i have to go now, but i'm doing a test render as we speak. I'll keep you posted as soon as i can. And after it's completly fixed i'll post my findings here so other people can benefit from it as well.

grts

JohnDoe22
11-17-2010, 11:23 AM
So my main problem was that there were multiple Physx World drivers... Now i only have 1.
The next problem is that Physx Collision Deflectors will always stay active, no matter what event they're placed in.

You've added a Melt modifier to my logo, so that the deflectors connected to them melted down, and had no effect on the particles anymore. But this solution 'slammed' all particles to the floor.
What i've done now: i detached the front of my logo, and animated the backside and frontside part of it out of the scene. The Physx Collision modifier was set to Animated Mesh.
But this doesn't seem to work, some particles do fly away, but most of them are still holding position, why is that? I need them to collapse on the floor due to gravity.

Any idea?

JohnDoe22
12-01-2010, 11:00 PM
problem solved:)
http://forums.cgsociety.org/showthread.php?p=6783906#post6783906

CGTalk Moderation
12-01-2010, 11:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.