PDA

View Full Version : exportFile #noprompt settings


FunkyBunnies
11-10-2010, 03:20 AM
I did a search through a ton of posts with little success, but I figured i'd make super sure. I'm having an issue with export settings when using exportFile with #noPrompt in a script.

Apparently some sessions in max don't export normals with our WRL exporter when run via script because of default settings used by the #noPrompt flag. Once the user exports a WRL manually with the dialog and the greyed out checkbox for "Export Normals" is ensured to be checked, the scripts work fine.

I'm using exportFile (fullFilePath + ".WRL") #noPrompt

So my question(s) is:
Is there any way to explicitly set settings for an export plugin but still silently export?
Is there some place to set the defaults upon max start up?
What could be causing the default behavior to be changed? (this error has occurred only on 2 of 10 machines)
Any particular ideas on how any of you've gone about solving this issue?

Thanks!

Myanko
11-10-2010, 08:50 PM
I was able to make fbx exportation working by making an exportation by hand, anywhere in my pc, with the settings wanted. Then by running the script after, it was taking in charge my settings. The only weird thing was that for fbx exportation, it wasn't keeping the export to ascii.

FunkyBunnies
11-10-2010, 09:40 PM
yeah, once anybody exports manually with the dialog and the greyed out checkbox for "Export Normals" is still checked, the scripts work fine. Somehow it seems like the setting is internally not defaulted to that or somehow it changes. It's never happened to me so I'm not sure how to reproduce it :(

CGTalk Moderation
11-10-2010, 09:40 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.