PDA

View Full Version : Render is different than what I see in viewport


th3ta
09-17-2010, 04:57 PM
I'm using Box#2 and running a sim of a grid of boxes falling. Pretty simple. However when I render out a frame it looks like it is actually rendering a frame later in the sim, and doesn't match my viewport at all.

Why is this?

EDIT: It's wierd, if I cycle through the frames and render them in order, sometimes they render the right frame, sometimes they don't. Has anyone experienced this bug? I'm running Max 2010 x64 SP1 on Win 7.

PsychoSilence
09-17-2010, 05:13 PM
First of all check if your viewport subsampling is the same as your render subsampling. With something dynamic like rigid bodies it's always a good call to cache out your particles to keep continuity when rendering on a network.
Depending on the complexity in your scene you can either cache it inside the physx world or with cache disk if you have the box3.

th3ta
09-17-2010, 05:18 PM
Yeah both are the same, as well as display %. I guess I'll try caching out the sim and see if that works.

JohnnyRandom
09-17-2010, 06:02 PM
Yeah both are the same, as well as display %. I guess I'll try caching out the sim and see if that works.

First rule of Box#2, always bake your particles before render! :D

PexElroy
09-26-2010, 07:41 PM
for box #2 or any flow, you want to add in a Cache op at the top of your flow. Set it to Viewport/Render and the RAM you want it to use, then jump ahead to the middle or end of your active time line to cache to RAM. If important save caches to disk (caches can get large, watch 'em). Once particles are cached they should match in viewport and render.

Another other way to cache a flow is to go to the PhysX World op and use the Cache bake there. If you can, grab v1.06, it has a feature to disable the Bake dialog window that could stall max (if you're using more than one cpu core). You can grab the latest files off the orbaz forums ;)

CGTalk Moderation
09-26-2010, 07:41 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.