PDA

View Full Version : Maxwell and background color


bordeauxcomet
09-05-2010, 02:39 AM
I want to be able to set the environment background color in maya and render the scene with maxwell. Whenever I render with sky options and image based lighting turned off, I just get a black background regardless of whatever was set in maya. Is there an option to set the background color somewhere in maxwell's settings?

Yes, I know I can render with an alpha channel and change it later, but that's not what I want to do. I'm just wondering if there's a way to set the background color directly and have it work the same way as mental ray, etc.

Thanks.

Jozvex
09-05-2010, 08:30 AM
Hi!

There's no official way to do it as far as I know, but it can be done. In the render below I stuck a plane behind the scene, gave it a material with the same colour for both Reflectance 0 and 90, then on the plane's shape node I turned on 'Hidden to Secondary Rays' and 'Hidden to Global Illum.'

http://www.jozvex.com/images/maxwellBG.jpg

At first I tried it with a sphere encompassing the scene but that still showed signs of shading which is not desirable obviously! For an animation with camera movement it would be trickier as you'd have to parent the plane to the camera etc I guess.

The other way to do it if you're not using the image based lighting feature, is to create an HDR file in Photoshop of your desired colour and load that as the Image Based Lighting 'background' layer, then turn off the other three IBL layers. This removes the issue of having to create geometry, but you have to tune the 'intensity' of the background to get it right. By default it'll likely be too low so you don't get the colour you specified (you get a darker version) but you can't just set the intensity to something huge like 1000 or you'll get antialising issues where your objects meet the background!

Hope that's somewhat helpful! :scream:

bordeauxcomet
09-05-2010, 11:19 AM
Thanks. Yes that was helpful. I had previously tried the HDR method you mentioned and ran into the same issues of being too dark or antialising. I'll give the plane option a try. I had tried something similar before but didn't have the 'hidden to secondary rays' and 'hidden to global illum' turned on, so that just may be the trick.

Still seems odd to me that there would be no direct way to do it...

CGTalk Moderation
09-05-2010, 11:19 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.