PDA

View Full Version : problem with find target


Sreekant
08-13-2010, 03:41 PM
Hii there..I've a scene in which particles are instanced to butterflies and these butterflies stick to a mesh which is at some distance above. The scene here is that the butterflies turns into a flag,but the switching of mesh to flag would be done in comp so no worries over that...
Now my problem is, I've used find target and have chose the mesh were the particles are supposed to stick,but my butterflies stop flapping the wing as soon as it stick to the mesh !!
My animation is of 100 frames and the particles action happen before 100 frames so running out of keyframes shldnt happen.....
Any suggestion....

Sreekant
08-17-2010, 03:37 PM
any help guys.....:(

JohnnyRandom
08-17-2010, 03:51 PM
If you can, drop the shape operator in the global, that should keep the animation offset, for some reason shape instance can lose scope in a local event when you use find target, don't know why.

EDIT: narrowed it down to "Find Target by Speed" is what kills it, if you use "By Time" the Shape Instance + animation should work in the local event.

Sreekant
08-18-2010, 01:27 PM
Hey John,seems like I'm doing all that what u said already.I'm attaching a file here,hope you have look at it.and as you can see, particles are not even sitting on the animated plane.
Thanks


P.s. I've kept the amount to zero in order to reduce the file size...Hope it works

JohnnyRandom
08-18-2010, 07:32 PM
Move the Shape Instance to the Global Event PF Source 01 and add a Lock and Bond to the Event 03 pick the plane object and set it to Lock to Surface enable animated shape and snap to shape, that should do it.

Sreekant
08-21-2010, 08:15 AM
Hey John...thanks man......it works now....:)

CGTalk Moderation
08-21-2010, 08:15 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.