PDA

View Full Version : HIK, FK not following IK


evengi
08-08-2010, 09:22 AM
Hi, Im working with mocap, and have used motionbuilder up until resent, now using Mayas HIK system. (2011)

My skeleton is characterized and a control rig is created.
When I translate my wrist effector(IK), the FK skeleton follows. Then I keyframe the effector in the timeline, making an animation of a arm moving.
Now, the FK skeleton doesn't follow the animated Effectors, but stays in is original position.
It seems I need to put keys for the FK skeleton as well as the wrist effector, is this right? Then how?


Tanks!
Roger.

rasamaya
08-09-2010, 01:23 AM
I think I get the same results, if I understand correctly.
I have(thinking it was because of the types of rigs I was using) then needed to create a new animation layer.
I then create a constraint(usually orient, except hips etc) for each control joint- the red dots constraining your original rig joints that where referenced in the character setup.
Under options of that constraint I need to select the animation layer and maintain offset.
That makes these connections much more intuitive for me.

No thinking about it, upon clicking my first frame of animation, my control rig matches my original rig. Yours looks off, unless its because of the animation.

Maybe I am missing something too.

Rasa

CGTalk Moderation
08-09-2010, 01:23 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.