PDA

View Full Version : .obj from Max is not smooth


pluMmet
07-22-2010, 05:55 PM
In Max it looks like this.
http://mysite.verizon.net/scanbay02/ArcheressMax.jpg


In zBrush it looks like this
http://mysite.verizon.net/scanbay02/ArcheresszBrush.jpg

Any and all import settings and programs welcome. Help!

oglu
07-22-2010, 07:28 PM
in zbrush all edges are hard... thats the normal behavior...
subdivide your mesh two times and keep on working...

pluMmet
07-22-2010, 07:46 PM
I divide to the max zBrush will divide without crashing then I make my cavity map and it looks like this.
http://mysite.verizon.net/scanbay02/CavityMap.jpg

That can't be right...

pluMmet
07-22-2010, 07:54 PM
And then I put that map back into Max and it does this.
http://mysite.verizon.net/scanbay02/BumpRender.jpg

All I want to do in zBrush is the high frequency stuff. I don't want to recreate the model inside of zBrush just so it's smooth.

pluMmet
07-22-2010, 08:05 PM
Here is checker on model
http://mysite.verizon.net/scanbay02/Checker.jpg

Very little stretching.

pluMmet
07-23-2010, 12:55 AM
Okay got it- There is a plugin for zBrush called SmoothGroupImport for Max. Worked like a charm :)

LoudNoises
07-24-2010, 12:05 PM
Hi,
Your map is also displaying incorrectly on the model in max because you need to make sure the flip uvs box is checked in zbrush when you export the maps. Zbrush flips uvs vertically. Also the smoothness in max is not a true smooth it is soften normals, zbrush is merely displaying the normals as hard.

Out of interest if you're wanting to create high frequency details in zbrush why don't you want to subdivide the geometry in zbrush. It is really what zbrush is for, you can drop back down to the lowest level of the model (the same level as the max model) and bake out a normal or displacement map.

pluMmet
07-24-2010, 01:22 PM
Hi,
Your map is also displaying incorrectly on the model in max because you need to make sure the flip uvs box is checked in zbrush when you export the maps. Zbrush flips uvs vertically. Also the smoothness in max is not a true smooth it is soften normals, zbrush is merely displaying the normals as hard.

Out of interest if you're wanting to create high frequency details in zbrush why don't you want to subdivide the geometry in zbrush. It is really what zbrush is for, you can drop back down to the lowest level of the model (the same level as the max model) and bake out a normal or displacement map.

Because I prefer to sculpt in Sculptris :arteest:

So I have a low poly cage that I made in Max and I divide it in Max and export to Sculptris. I only just found out that Sculptris does not keep my original UV's so I had to make UV's at this higher division level.

AFA flipping the map I have a zBrush setting in Max when exporting .obj and I know that it does that so I don't know why it wouldn't have? But I can't tell just by looking at the UV map. How are you able to tell by what I have shown?

LoudNoises
07-26-2010, 01:52 PM
"AFA flipping the map I have a zBrush setting in Max when exporting .obj and I know that it does that so I don't know why it wouldn't have? But I can't tell just by looking at the UV map. How are you able to tell by what I have shown?"

It isn't the uvs it is the texture map, as uvs in zbrush are flipped from how they are in max you need to flip any exported maps when applying them in max. When you export a map from zbrush you need to check an option to flip the map.
In the picture in your third post the map appears top be displaying the edges of the uv islands, which is why some areas are flat and others have the raised bits. You don't need to alter the model/uvs to sort this you either need to check the box in zbrush or flip the texture file in photoshop/gimp etc.

designingpatrick
08-08-2010, 05:03 AM
It doesn't seem like your problem was solved... I'm having the same issue; faceted normal maps.

pluMmet
08-08-2010, 04:15 PM
It doesn't seem like your problem was solved... I'm having the same issue; faceted normal maps.

Using the plugin for zBrush called SmoothGroupImport looks only slightly different in the zbrush viewport but it is better on the exporting of maps after your done in zBrush. It lessens the problem considerably. It is however still there.

I have come to the conclusion that I need to yet again do a retopo on her to get rid of this problem with zBrush but I'm waiting until Tuesday to see the zBrush4 will handle it better.

designingpatrick
08-08-2010, 07:46 PM
I downloaded and installed the free xNormal- it did a much better job than zBrush- plus it was quicker and has more options. I don't like adding extra programs to my workflow, but in this case, it seems to be worth it. It'll create normal, AO, displacement, cavity, etc.

CGTalk Moderation
08-08-2010, 07:46 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.