PDA

View Full Version : mia_portal_light makes invisible objects behind it visible


rchr
07-14-2010, 05:47 AM
Hey All, I'm trying to figure out this mental ray puzzle on the relationship of reflections and objects in Maya 2011 hotfix 2 Windows 7.

As you all know, Area lights in Maya has a very harsh rectangular shape when it is visible and this also creates a fairly boring looking reflection on to an object, so my aim is to create a different shaped object or texture to reflect on to the object and I want any reflectors in the scene to be Invisible to the eye, but still visible in reflections.

Note: FG is used and Mia_exposure_photographic is used for linear workflow.

So I created a poly "reflector" object with cast/receive shadow and cast/receive FG turned off. Also, Primary Visibility is turned off

Then created Maya Area Light -> Converted to MR Area Light -> mia_portal_light plugged into light_shader and photon emitter slot. Added mib_blackbody in the custom environment. Visible is unticked.

Put reflector object slightly behind the Area Light. Notice that even though the primary visibility is turned off, it is still visible if it's behind the Area Light. According to Maya manual, there is a section on troubleshooting Mental Ray on how "Object still renders when primary visibility is turned off" its solution is to disable the Visible in Transparency flag. With this method, now the reflector object is invisible when rendered. However the reflection has also disappeared. If I untick "visible" under the Area Light shape, Mental Ray will spit out an error "Shader 'mia_portal_light' must be applied to a VISIBLE rectangular area light to work correctly!"


1. Is there a way to get around this? Is there a better method to do what I'm after?

2. MasterZap once mentioned that in Maya it's better to use Spotlight converted to MR Area Light. Does this still apply for the new Mental Ray in Maya 2011? Or just stick with Maya Area Light converted to MR Area Light.


It's best that you look at the scene file to analyze. Scene file attached is a Maya 2011 version but you can open it on any version. Go File-> Open scene "option box"-> tick Ignore Version.

irwit
07-14-2010, 03:14 PM
Stupid question ( maybe ) but is your board visable to refractions ?

If not that you have a slider in your portal light settings to "see" whats behind it. Maybe try changing thats value ( i dont have mental ray open right now so cant tell you the name of this)

rchr
07-15-2010, 02:33 AM
Hi irwit,

I've tried both of your suggestions, Transparency slider in the portal light must be white otherwise it will turn black.

Turning the reflector visibility to refractions and transparency also does not work as expected.

http://img130.imageshack.us/img130/7742/transparencyblack.th.jpg (http://img130.imageshack.us/i/transparencyblack.jpg/)
http://img444.imageshack.us/img444/4461/notvisibletransparency.th.jpg (http://img444.imageshack.us/i/notvisibletransparency.jpg/)
http://img687.imageshack.us/img687/1549/notvisiblerefractions.th.jpg (http://img687.imageshack.us/i/notvisiblerefractions.jpg/)

achoury
07-15-2010, 08:55 AM
hi
select your reflector hit ctl+a, under the Flags (transform not the shape) uncheck Derive from Maya
Hide: on
Visible: no
Trace: no
hop this help
/Rachid

rchr
07-16-2010, 05:24 AM
Hey Rachid, that still doesn't work. It removes both the reflector entirely, resulting in no reflections on the object.

Under the Mental Ray Flags option under the Attr. Editor of the reflectors. It seems that regardless, whether 'Visible' and 'Trace' is yes or no, as long as the 'Hide' is ticked. It will remove the reflector completely, including their reflections on the object.

TinyCerebellum
07-16-2010, 04:03 PM
It seems like the simple and practical solution would be to just move the reflector objects in front of the light, as opposed to having them behind the light. However, that obviously doesn't solve the problem in itself. I tried turning off the Visible checkbox in the mr Area Light rollout for the lights, and MR does indeed spit out the error. However, the render still takes place with no significant noticeable difference.

wizlon
07-19-2010, 08:20 AM
I second that. Just make the objects single sided and move them in front of the light.

rchr
07-19-2010, 04:26 PM
Thanks guys, I guess I will have to do that then. :)

Is this a Maya bug or just a limitation of Mental Ray? Can anyone confirm if this happens as well in Max/XSI?

CGTalk Moderation
07-19-2010, 04:26 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.