PDA

View Full Version : Key the camera environment


escooler
07-05-2010, 11:31 PM
Is there a way to key the environment colour on a camera. I want to increase the ambiante light in my scenic over a short period using final gather but I cannot seem to key this attribute anywhere, I even tried putting a keyed lambert on it, but it was having none of it...any tricks here???1?

a

animatedfox
07-06-2010, 03:43 AM
One way to get a similar effect as using a non-black Camera Environment, but with 100x more control is to tap into the Image Based Lighting options in Mental Ray.
As you are using final gather, I assume you have found your way to the Indirect Lighting tab of the Render Settings. Just click "Create" next to Image Based Lighting under the Environment tab.
By default this is setup to work with an image file such as an HDRI...which is a great thing to use if you have an image...but, you can also just use on of Mayas procedural textures (such as a ramp in this case). Just select "Texture" under Type (by default is set to "Image File")
This will gray out the Image Name box and enable the Texture area.
Here you can just set a basic color and key as needed...OR click the familiar checker box to select any other texture to connect. I would recommend using a ramp and animating that a bit to get a little more finesse out of you colors.
Just to make sure...you need final gather on to see the hot image based lighting effect that i described.

This should be enough to get you started, but there a ton of options/quality settings to improve/ruin your image...check out maya help to get a little more info before things get too out of hand.
All the best..
~Ben

escooler
07-11-2010, 06:20 PM
Hi,

Thank you for your response. i understood it perfectly. However I have suffered a little with the execution....I keep getting the following error message in my renders screen.

mentalrayIblShape1: IBL ignored. File texture not found, or constant black input color.

Am I correct in assuming that its saying I cannot key the base environment....That is... forbidden.

pbraganca
07-11-2010, 06:49 PM
According to the error it seems that you forgot to plug a texture in the IBL Texture Slot as suggested. Keying the camera its also possible if you select it, go to its attributes and under the Environment tab after selecting Background Color right click on the "Background Color" and Set Key.

CGTalk Moderation
07-11-2010, 06:49 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.