PDA

View Full Version : Mirror Joint tool not mirroring Behaviour


kpamir
06-25-2010, 12:57 AM
Hey guys,

I am in the process of rigging one of my character models, and I cannot figure out what exactly I am doing wrong. I have my joints oriented , and half of the skeleton set up and when I attempt to mirror the arms and legs over to the other side the behaviour is not mirrored despite my having checked off the box in the option box.

So for example if I select both arms at the shoulders and rotate in, the right arm rotates in across the body where as the left arm rotates out to the side of the body, instead of mirroring the right arms behaviour.
.
I am using Maya 2011.

I am fairly new to rigging so this is probably a very straight forward and easy problem, but I haven't been able to find any issues like this online despite my many attempts.

If anyone could help it would be greatly appreciated.

Thanks!

Darksuit
06-25-2010, 04:41 PM
Without seeing a screen shot it's sort of a guess at what might be happening. So let me detail how I might mirror my joints.

I'll build out the arm and then name the arm. (Usually I use a naming convention that leads with L_ or R_ for left or right.)

I will then parent that arm hierarchy into the spine where I want it. Usually to the clavicle then the clavicle to the Spine_Chest.

Then I click on the Clavicle (the first joint in the chain for the arm) and select
Skeleton > Mirror Joints > Optionbox.

With the option box window open I will set the name replace to be L_ to R_ this will reduce the amount of renaming that you have to do. Also you can select to Mirror Behavior here. So that the joints will mirror their actions.

Ususally I am setup so I can use the YZ axis Plane you may have to experiment to find the right plane axis for your rig.

kpamir
06-25-2010, 05:16 PM
Those are pretty much the same steps I am taking.

Here are some pics.

The first pic I checked off behaviour for the mirroring, and the second I chose orientation.

Both give me the same outcome with the way the arms move. Behaviour should give me mirrored movement. So the right arm moves in then the left arm does the same thing. At least that is the way it worked in 2010 and older.

behaviour

http://lh5.ggpht.com/_nyXPWzJhZG4/TCTVyRrnEXI/AAAAAAAAA2E/C8zKW1ZXIig/s800/mirror_joint_1.jpg


orientation

http://lh6.ggpht.com/_nyXPWzJhZG4/TCTVyl-ni5I/AAAAAAAAA2I/TyWBzZGBVaQ/s800/mirror_joint_2.jpg

gonzalimator
06-25-2010, 07:51 PM
I think that it's your Rotate Tool's rotation mode. It looks like it might be set to "Global". Change it to "Local" or "Gimbal" and you should see the correct behaviour.

kpamir
06-25-2010, 09:58 PM
Thanks Gonzalimator, that fixed it.

CGTalk Moderation
06-25-2010, 09:58 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.