PDA

View Full Version : MR sun & sky w/clouds producing ugly shadows


mactoons
06-24-2010, 08:53 PM
I am using zap's setup for clouds using mental ray's sun & sky and hooking a cloud map into haze. I like the results except for the shadows it produces which don't look very natural to me. I realize in my example I am repeating the map enough that it makes it look extra bad but is there any way to either soften or turn off shadows coming from the haze?

techmage
06-25-2010, 12:58 AM
I didnt think haze clouds casted shadows...

whats on your red van there doesn't look like a cast shadow to me at all, it looks a texture mapped onto the side of the van

mactoons
06-25-2010, 02:05 AM
Yeah, not sure what's up but I think they are shadows. On the ground they don't look so bad but projected on the truck there they do look sort of like a mapped texture. I know they are coming from the haze though because when I disconnect the file there are no shadows. Anybody else have this issue?

mactoons
06-25-2010, 06:30 AM
Still not sure what these shadows are and how to fix them but there is another problem I am having with the physicalsky shader. I have set a visibility distance so that there is some fog in the scene but looking through a window with a mia_material_x glass shader the fog is not visible. Is this a ray tracing issue?

VanDerGoes
06-27-2010, 03:17 PM
These are not shadows, but the reflection of the haze map in the van material.

mactoons
06-27-2010, 06:39 PM
Not sure if it is reflections, I'm getting the artifacts on a default lambert shaded object as well...

VanDerGoes
06-27-2010, 06:55 PM
How did you connect the texture file to the haze?

mactoons
06-27-2010, 07:48 PM
I tried 2 different methods, connecting a file node to a luminance node to a multdiv (multiplying by 9) and into haze. I also tried connecting a file node directly into haze and setting "alpha is luminance" and adjusting the gain up. Both give me the same results...

VanDerGoes
06-28-2010, 12:08 AM
My personal workflow is: mentalray texture>mib_lookup_spherical>multiply_divide> luminance> haze slot of the sky node.
I hope that helps.

ytsejam1976
06-28-2010, 07:25 AM
disconnect the connection between haze Sky and haze Sun

mactoons
06-28-2010, 07:44 AM
Awesome, that fixed it! Thanks for the tip...

CGTalk Moderation
06-28-2010, 07:44 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.