PDA

View Full Version : BlendShape Problem, Plz Help


jamil1985
06-24-2010, 04:33 PM
Hey, im facing this weird problem with blend shape in maya, can any1 help me plz? the problem is, i finished creating simple eye blink blend shapes for my character, selected them in order and created a basic local blendshape. I used jason Osipa's blendshape ctrls to ctrl my blendshapes. It worked fine, whenever i slided the ctrl down the eye lids shut nicely. However, with the eyes shut i selected my head ctrl&rotated it to the side, the blend shape didn't follow! it just messes up as if the eyelids are pinned? I never faced this problem before when i had to create my rigs manually (Im using Anzovin's Setup Machine to rig my characters), i have realized that im facing this problem with every characters that i made for this project. This problem happens only when the head is rotated in any direction, the eyelids seem to offset. For the face and eye lid ctrls i used Clusters to move parts of the face and then Reoriented the Cluster handles for each clusters by replacing the weighted node to the ctrls that i made for the face. These ctrls are grouped and then parented to the head. I included images below.

Your help is appreciated.

Kind regards,

Aj

Impact
06-24-2010, 07:12 PM
Hi.
When creating a blendshape on a skinned character be sure to check "Front of chain" in Deformation order list from create blendshape option's advance tab. Or you can manually change order of inputs in object's input list: right clock on object then inputs> All inputs then middle drag to move them.

jamil1985
06-24-2010, 10:54 PM
Thanks! ur a life saver lolz! Ive been struggling with this the whole day! It worked! Such a simple problem can give a headache. Many thanks!

Kind regards,

Aj

CGTalk Moderation
06-24-2010, 10:54 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.