PDA

View Full Version : Shadow Map Flicker - Just cant figure it out...


Stellios
05-30-2010, 05:27 AM
http://www.youtube.com/watch?v=RQ_aA7ax17k

underneath the right ear some strange black artifact is flickering on and off. I made a thread (http://forums.cgsociety.org/showthread.php?f=87&t=878810&highlight=shadow+map+flicker) that included this question but there have been no solutions to solve the flickering.

My new shadow settings are:

Detail Shdow Maps

resolution 1024
samples 32
softness .020
bias .01


However im not sure this is a shadow problem, i tried rendering the scene without the hair, on a normal blinn surface with the same light setup and the artifacting is gone. This makes me think the problem lies within shave and a haircut?

Im using mentalray, rasterizer rapid hair preset. Using hair primitives as the hair render mode.

Please please please help!

ps, no "use puppet shader" responses please

kiryha
05-31-2010, 07:51 AM
Wery short and low quality video- difficult to recognize problem.
It is not recommendet to touch bias, so any way set bias=0. Shadow flicker cures by rising samples in detail shadow map section.

Stellios
05-31-2010, 08:42 PM
thanks for the advice.

Well, i removed the shadows completely from the scene and the black artifact is still there. so apparently this has nothing to do with shadows at all, and is a shave and a haircut problem. cheers to another can of worms.

Stellios
05-31-2010, 10:06 PM
UPDATE:

So ive started to tweak a setting at a time, isolating the head so that it wouldn't take so long to render as i troubleshooted each setting. To do this i lowered the hair count to 1 on all hair systems but the head and chest. In doing so i noticed something... The artifacting was gone.


Simply by lowering the hair count on the leg and arms hair systems to 1 hair each. The artifacting in the head system is gone. So, shave gurus... What exactly is my problem here, if this solved the problem (of course introduced a new one)

Heres a before and after:

http://i47.tinypic.com/34o4gw0.jpg

http://i45.tinypic.com/120icrl.jpg

its a bit difficult to see whats going on, but there is a dark edge underneath the bears right ear, if you quickly jump back and forth with your eyes you can see the difference. Seems subtle but during animation when viewing it high def it sticks out like a sore thumb.

Stellios
06-01-2010, 02:46 AM
problem was soved by increasing the voxel resolution in the shave globals.

:)

kiryha
06-01-2010, 09:00 AM
From now you definitely need to setup scene with p_Hair_TK and compare results:)

CGTalk Moderation
06-01-2010, 09:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.