PDA

View Full Version : Maya nParticles bug or...?


kdronez
05-24-2010, 08:47 PM
Well I watched one clip in youtube where one dude made instant ice from water so I decide to try and make smth similar in maya,but this is what happened.
I used Particle Collision Event Editor and played a little bit with self collide options in nParticles tab,but when I tried to convert the 2nd nParticles to mesh they just disappeared.So now I cant see the mesh.When I convert the 1st nParticles theres no problem T_T.
Did I miss smth or....?Any options that I should turn on?

pic (http://www.image-upload.net/viewer.php?file=buv9c4d2aso7o7sbmsz.jpg) -frame 37
Red balls I was planing to convert and use for water and blue balls for that icy thing.

Aikiman
05-25-2010, 09:56 AM
Hi Kdronez,

I think it has to do with the radius and threshold settings on the mesh . Ive played around with that too and Maya 2011 now makes the particles invisible when you convert them to mesh, and if you dont have the mesh settings right you dont see anything.

So increase the blobby radius to see your mesh, and to see your particles again go to object display and turn off intermediate object, although having this off is quite handy as it reduces sim times.

Duncan
05-26-2010, 12:38 AM
There are a few typical things that result in no output mesh.
1. mesh triangle size is too large
2. the bounding box of the particle has gotten so large the max triangle resolution has been exceeded. When this happens the triangle size will automatically increase to keep from exceeding the resolution. Just one particle falling down can cause this to happen fairly quickly. The effect is that your mesh resolution gets lower until eventually it disappears completely. One should try to limit how far stray particles can go out of view to avoid this problem. If needed one can increase the max triangle resolution, but at a certain point it can get slow and potentialy run out of memory for large values.
3. The threshold is higher than the summed particle densities. If particles do not overlap then there is no surface if the threshold is 1 or greater. For very smooth meshes one can use a high threshold, but then the blobby radius scale also needs to be high so there is a lot of overlap.

Duncan

kdronez
05-28-2010, 10:29 PM
Thx for the info guys.It rly helps alot,but I couldnt continue with that scene,becouse I started to run out of memory xD.O well next xD.

CGTalk Moderation
05-28-2010, 10:29 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.