PDA

View Full Version : moving particles along surface without penetrating it?


wannabeArtist
05-21-2010, 10:55 AM
Hi,

Related to my condensed water thread, but as a separate question: How do you stick particles to a surface while moving them?

I have tried speed by surface with control speed continuously, but my particles tend to get inside the surface rather than follow it's contour. Any tips?

thanks!

wannabeArtist
05-21-2010, 11:45 AM
Here are some screenshots to show what I mean. The bubbles start their climb nicely following the inside surface of the glass. However, once they reach a certain distance, they start to "sink" inside the glass (third shot) - how do I keep them on top of the surface?

scrimski
05-21-2010, 01:18 PM
Use a nonrendereable proxie mesh for a deflector and use push modifier to set the walls a bit inwards.

Maybe a speed by surface operator with a slight offset works too.

wannabeArtist
05-21-2010, 02:03 PM
Thanks,

I will try that. In the meanwhile I tried playing with the accuracy settings (acceleration limit and integration step) as well as a coarser and a denser surface mesh, but got nothing but gray hairs, maybe the deflector will work better.

naik
05-21-2010, 02:48 PM
You have to crank up the density of your mesh in order to get better / correct results.
What shape do you have? Hemispheres?

If you mesh is dense enough, you will have no intersections...

I did a test and it looks very good.
pflow --> Position Object --> Shape Instance --> Speed by Surface --> Rotation ( Speed Follow )

Also check the Surface offsett value in the Position Object operator.


cheers

Naik

wannabeArtist
05-21-2010, 03:27 PM
Hmm,

I don't know what I did wrong at first. I tried it again with a slightly different cup (basically a hollow cylinder with some curvature) and it worked - at least they stopped sinking into the glass.

But there are still some issues, like skipping frames: How do you make this run smoothly?

With just 100 particles (instancing a very coarse hemisphere) it is a very jagged movement - it seems to skip frames. I'm doing this with a rather fast computer, so it should not be the issue, but rather my incompetence with the settings. I don't know much anything about animation, but I messed around the time control dialog and it seems to run a bit better if I set it to 1/4 speed (still skipping, though).

I have set the speed to just 1,0 mm as well as the acceleration limit. I have no idea if they are reasonable, especially the latter, but the idea is to have the particles rise calmly for a distance of maybe 2,5 cm.

naik
05-21-2010, 03:48 PM
Maybe you have to crank up the integration steps for your scene.

I will be not in front of my workstation.
But if you could upload your scene i can definately check it out
at home.

The rising speed shouldnt be a problem.
There you have to setup a correct value for your speed operator
(maybe some variation ? )
Also you have to set the speed to "Control Speed continously"...

cheers

naik

wannabeArtist
05-21-2010, 03:49 PM
Thanks!

Actually I just got it to work pretty nicely - I found the cache operator :D

It seems that Pflow is not multi-threaded? I checked out task manager while it was caching and only 1 of my 4 cores was at work. Well, that explains the performance issues, I guess.

I have one more issue of my hemispheres flipping upside down towards the end of the animation. If I cannot solve it during the evening, then I will upload the scene.

naik
05-21-2010, 04:02 PM
Glad that you could fix it.

no problem, see how far you get.

good luck

wannabeArtist
05-23-2010, 05:02 PM
After quite a few tests, I'm becoming more and more willing to "fake" this effect with maps instead - it seem rather difficult to achieve a realistic look after all.

CGTalk Moderation
05-23-2010, 05:02 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.