PDA

View Full Version : Problem Transferring UVs


ultimateoverload
05-20-2010, 07:50 AM
Not sure if anyone has run into this problem..

I used the UV Master plug-in to lay out UVs on a particular model and now I'm trying to transfer the new UVs to another mesh of the same model after being rigged/animated in Maya.

I brought in the model from ZBrush with the UVs laid out as an obj into Maya where I have the same model rigged/animated. I know sometimes when you transfer UVs between meshes sometimes you cant get rid of one of the models because they somehow get linked. So what I did was go to the hypergraph and display hidden nodes. After finding the original node I went to the attributes window and unchecked 'intermediate obj' and transferred UV information to that node, then deleted history.

It seemed to work fine, but after putting a test texture on both models I noticed the rigged/animated model was all jagged like. The UVs I had transferred to the rigged/animated model somehow split into several different shells even though the model I transferred from was one single shell.

I was told it may have been the way I exported from ZBrush, but I checked the settings and even re-exported just in case. I checked UVs (all one shell) once I go to transfer the UVs (multiple shells)

Possibly the problem is in the 'transfer attributes' settings?
http://img32.imageshack.us/img32/7792/toapk.jpg

Been on this for a bit and still cant get it to work..

Anyone having/had this issue before?

GatorNic
05-23-2010, 02:26 AM
Double check your vertex order to see if it changed, that is the most likely cause. Normally ther vertex order gets screwed up on import to Maya when in the obj import options it is set to "Multiple Objects". Make sure it is set to the single object option.

If the vertex order has changed and you can't seem to get it back to the original without reworking it, change your Sample Space in the transfer options to World Space. This will transfer UV's regardless of vertex order because it is closest point based. Just make sure that the two meshes are directly on top of each other. Only down side is its possible to get a jumping UV or two where two points are extremely close, that's why the local or component options is preferred when you have the exact same mesh with correct point order.

ultimateoverload
05-24-2010, 01:43 AM
Thanks for the reply nix21..
This was driving me crazy for a few days. Never thought to put the meshes on top of each other when messing with the settings under 'transfer attributes' - that totally did the trick. Thanks again =)

CGTalk Moderation
05-24-2010, 01:43 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.