PDA

View Full Version : Matte Opacity: Black Holes issue


my7hai
05-18-2010, 07:09 AM
Hi there,

I am currently rendering a project where beerbottles are playing soccer with maya 2010 using MR.
I used the the "Matte Opacity: Black Holes" (Lambert Shader) to make cutouts so i have the players and the soccerfield seperately.

But when i go to aftereffects, the Cutouts dont match the players in various frames, and i cant figure out why.
Even if i bring the frames to photoshop, you can see that the cutouts dont fit the players.
its like the Cutouts of the Blackhole Shader are lagging behind half a frame or so.

The "players" (beerbottles) are animated, and have several controls controled by blendshapes.
I am rendering in 32 bit float, open EXR, and using the sun and sky.

I hope one of u guys can really help me out, because its pretty important to get this done.

Thanks a lot in advance, appreciated!
http://farm4.static.flickr.com/3331/4617582237_87561f6c05_o.jpg

Guacomodo
05-18-2010, 03:20 PM
Are you also rendering a motion vector pass or have motion blur enabled on one layer but not on the others?

my7hai
05-19-2010, 08:59 AM
hi!

yes actually i do!
and i think thats the problem..

im not quite sure how to render the motion vector pass now though (i dont really need it anymore
since some aftereffects plugins do a quite good job)
in a seperate pass with the rendervisibility turned off in every pass? hmm..

thanks a lot for your help, appreciated!

Guacomodo
05-19-2010, 09:22 AM
Well it is a matter of finding the right settings so the images are alwas rendered on full frames and not between those.
The things I generally do is set shutter angle in the camera to 180 and then play around with the motion back offset by setting it to 0 or 0.5 or 1.0.
I would first render a frame without motion blur and then one with blur and check if they match.
You can set shutter open and close both to 0.5. This way only the vectors will be calculated and no blur is applied to the image.

my7hai
05-19-2010, 02:29 PM
thank you so much for your help!
vielen vielen dank! :)

CGTalk Moderation
05-19-2010, 02:29 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.