PDA

View Full Version : nCloth key frame "enable" & Fields


destruct007
05-13-2010, 12:21 AM
I noticed that nCloth acts significantly different with fields depending on when it's enabled.
Make a cube dup 10 out next to each other but not touching. Make them all nCloth. Add a volume axis to them all. Turn them all enable off, key frame and then key frame them on next frame. Shift each one, a frame or two and play, you'll see they act as tho the force is building up as they are off. I've had othertimes that I've had to turn my forces up to 1,000,000 mag to get them to react after being keyed on so much later. basically I don't know what the deal is with them and why they are so unpredictable with fields.
My work around has been to make a separate solver for each cloth object but obviously that has its own challenges. Anyway, anyone else have this issue or know a solution?

destruct007
05-13-2010, 12:25 AM
added example file. You'll notice the ones that get keyed on later fly away like crazy while the ones that turn on earlier react as expected.

Oh and maya 2009 on this one.

EDIT: just tested it in 2011it works fine in 2011. hah great :( doesn't help me on this show.

rxgeez
05-13-2010, 01:59 AM
I took a look at your file and the first time I played it back it played properly....as soon as I replayed it it resulted as you said. Looks like a bug to me.

A work around besides a new solver for each could be to break the .startFrame on each nCloth from the nucleus and set it to the same frame you key on the enable....or better yet just set the start frame instead of keying on enable...probably not the most ideal way but it works.

the startFrame attr can be found under the "time attributes" tab on the nCoth node....good luck

HowardM
05-13-2010, 05:53 PM
strange lil bug!

you could instead leave them fully enabled at start, and toggle the Input Mesh Attract to 'release' them, that definitely works.....
or check out my other post, where you can use an animated ramp to trigger a field in a cooler way, may help - http://forums.cgsociety.org/showthread.php?f=86&t=866651

you know where to find me if you want more help ;)

Cheesestraws
05-13-2010, 06:52 PM
If expressions run on nCloth objects that aren't enabled you could use an expression to set the fieldname_magnitude to 0 when the cloth isn't enabled. Add attributes won't add per-particle attributes by default when you have an nCloth object selected though, so you have to use the command manually.

destruct007
05-13-2010, 09:26 PM
you could instead leave them fully enabled at start, and toggle the Input Mesh Attract to 'release' them, that definitely works.....
or check out my other post, where you can use an animated ramp to trigger a field in a cooler way, may help - http://forums.cgsociety.org/showthread.php?f=86&t=866651


Awesome! Thanks for the trick and workaround, this will definitely come in handy.

HowardM
05-14-2010, 04:59 PM
no worries mate, that method maybe overkill for your shots..
did you try keying Input Mesh Attract?

CGTalk Moderation
05-14-2010, 04:59 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.