PDA

View Full Version : Some Muscle Issues


MrMint
05-02-2010, 09:05 AM
Looks to me like maya-muscles are not so easy to setup as I thought and I hope someone can point me to the information I am missing to fix these issues.

- I have a character rigged (basically its made like the gnomon "puppet rig") where I mirrored the limbs behavior.

As I haven`t found many free tutorials on this issue I am following the muscle-workflow as suggested from the manual

- So I had to select each limb and converted them to capsules because of the different axis
- Applied the muscle-deformer to my character and kept the skinCluster.
- Created for both sides biceps and pectoral-muscles (via duplicate and scale set to -x)
- applied muscle-spline-deformer to them and parent-constraint the start and insertion-handles to the appropriate joints/capsules
- now I noticed that I should add another capsule for the elbow-deformation so I created those and parented them under the elbow. Additionally I made a low-poly ribcage for the pectorals to slide on.
- selected all the joints, the muscles (nurbs) and the character and did muscle objects -> Connect selected muscle objects (auto-calculate).

Now there are some issues:
- It seems like my skinCluster has been messed up. When I rotated the spline, huge parts that had been set to the pelvis are moving
- When I am painting the sticky-weights for my biceps the verts are moving. If I apply 100% to my left arm they will go back to the initial position but the right-biceps will shrink.
- When I am moving the character I get double transformation on my right biceps although I havent treated it any different from the other muscles.
- When I rotate the clavicle only the joint will move while the capsule-shape stays in place.


SplineRotate

http://img265.imageshack.us/img265/7745/spinerotate.th.jpg (http://img265.imageshack.us/i/spinerotate.jpg/)


R_Biceps/sticky (100%) .............................................L_Biceps/sticky (12.5%)

http://img263.imageshack.us/img263/1/rbiceps.gif (http://img263.imageshack.us/i/rbiceps.gif/)..................http://img441.imageshack.us/img441/5750/lbiceps.gif (http://img441.imageshack.us/i/lbiceps.gif/)

clavicleRotate

http://img443.imageshack.us/img443/8123/clavicle.gif (http://img443.imageshack.us/i/clavicle.gif/)


Thank you for chewing through this post :bowdown:

tpalamar
05-02-2010, 01:06 PM
Creating a muscle rig is a complex task. You should do one step at a time and test at each phase. The first thing I noticed was that you duped a muscle by scaling in -X. You need to use the mirror tool inside of Muscle Creator or create the muscle from scratch. Anything you do with the duplicated muscle will have problems. Your right bicep is shrinking most likely because its normals are flipped because of the negative duplication. Next the skinCluster node is not going to update with your new muscles and capsules. You will have to paint new weights.

I would start over at the point that you converted to capsules. Test the rig at that point. It seems that some of the capsules didnt connect properly. This might of happened because of the rig hierarchy.

MrMint
05-04-2010, 09:24 PM
Thank you very much for your input.
Seems like something has been messed up on the way and starting over again worked out pretty well.

MrMint
05-06-2010, 09:42 AM
Ok, here is an other one,

- whenever I create a smartCollide for my right hip (neg X-Axis) the plane turns red (usually indicates that something is wrong) and it is created at an completely different angle than the leftHip-collidePlane.
- The collisionNode will always stay at the end of the paintWeights-list.
- Any other collisionNode created/connected afterwards will move vertices as if they are connected to an other node when painting weights.

http://img156.imageshack.us/img156/6291/smartcollide1.th.jpg (http://img156.imageshack.us/i/smartcollide1.jpg/)
http://img532.imageshack.us/img532/9353/smartcollide2.th.jpg (http://img532.imageshack.us/i/smartcollide2.jpg/)

Last time I simply started with a skinning-messed-up-mesh (still wondering how I did that) but this time this is not the case.

MrMint
05-07-2010, 11:13 AM
Seems that it doesnt like my LocalRotationAxis.
So this will happen when the LRA`s are more or less pointing to each other

The only workaround I can think of is creating a duplicate of one of the joints, reverse the direction and make the smartCollide with this one. Though it behaves the same the deformation is not. This is the point where I have to stop due to lack of deeper knowledge.

Perhaps I did something wrong on this "workaround", so here is how I have done it:

- duplicated the joint-hierachie and deleted everything below and above the pelvisJoint and R_hipJoint
- reversed the Aim-Axis (x) of the duplicated R_hipJoint
- deleted the copied pelvisJoint
- parentConstraint the duplicated R_hipJoint to the original
- mirrored the skinWeights from left to right
- created the smartCollisionPlane with selected pelvisJoint and copied R_hipJoint
- connected the smartCollsion with the muscleDeformer

This is the process which brings me the closest to resolving this issue. But the deformation is not really mirrored.

CGTalk Moderation
05-07-2010, 11:13 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.