PDA

View Full Version : Mental Light Shape Visable in rendering is not visable??


fabw
04-08-2010, 08:52 AM
Hi,

I have a problem and I cant solve it.
I use mental ray, photometric lights, I check option "Light shape visable in rendering" but it dosen`t work.
I searched google but no answer.
Please help.

JeffPatton
04-09-2010, 12:52 PM
If you're trying to render just the light source without any geometry (deleted or hidden), then the visible option on the photometric light won't work. So make sure you have some geometry in the scene...or you could always use a self-illuminated plane to represent the light source instead.

Beyond that, not much that can go wrong with it. Just make sure it's visible to the camera and the normal/direction is visible to the camera as well.

fabw
04-09-2010, 07:54 PM
Thanks.

I render in a close room. Light shape is a rectangle 8cmx8cm near ceiling.
Unfortunatly I cant see light shape:( (I see black shape when FG is calculating but after randering no shape or any illumination). I dont know why.
Only see shadow from this shape on the ceiling.

I have tryed other room and no change.

I have read once somewhere that I need to run script manualy but dont know how and what is about.

JeffPatton
04-10-2010, 02:27 PM
You don't need any special scripts to make this work. Here's a list of some things that would make it not visible in your render:

1. Make sure there's geometry in the scene.
2. Make sure the light isn't behind some geometry that would block it.
3. Make sure your exposure settings allow you to see the light / the light is bright enough to be visible in the render.
4. Make sure the light source is visible to the camera.
5. Make sure the lights direction isn't reversed/facing away from your camera.
6. The "Light shape visible in rendering" option is disabled.
7. A light shader has been applied. *

* This may or may not make the light shape invisible, just something to check if you've assigned a light shader to the light.

fabw
04-11-2010, 10:25 AM
Hmm. Point 6 and 7. I am new in max so still make a lot of mistakes.
I thought I have to enable "Light shape visable in rendering" in a shape/area shadow tab?
What about point 7? How to add light shader?

I have tryed to add and enable light shader in a mental ray light shader tab but now light was seen in a scene then.

Once again. Maybe i do sth wrong. I create photometric light, light distribution - photometric web, add ies light, set intensity to 190.000 cd ( I use daylight system), enable "light shape visable in renndering" set to disk 5 cm radius (this time).Render

I see IES light in a scene but no disc illuminatings, only shadow from disk on a ceiling.

JeffPatton
04-11-2010, 02:48 PM
no, no, I think you've misunderstood the point of my previous post. Those points are simply possible reasons why the shape would not show up...it's not a list of things you have to do to make it work.

If you haven't assigned a light shader to the light then don't worry about it because that's obviously not the reason why the light shape is not rendering.

190.0 cd is not much light at all when compared to the sun. So I bet this is simply an exposure problem. If you want the light balanced so you can see the 190.00cd light, then you need to adjust your exposure control to that light source just as you would a real camera.

For more info, see point #21 in my mental ray FAQ: http://jeffpatton.net/forum/index.php/topic,4.0.html

fabw
04-11-2010, 04:17 PM
Jeff I understend you well. I just wanted to go through point 1-7 to check if i am not wrong with sth but seems not.

I said 190000 cd not 190 cd. Lights are in the scene but shape is not.

Lets see on this rander.

http://img413.imageshack.us/i/kitchenj.jpg/

This two shadows on the ceiling are from IESs circle shape but no shape there?

After all can you please comment this render. This is my first render. What I can improve? What to work for?

JeffPatton
04-11-2010, 05:06 PM
Afraid I don't know then. I've never personally encountered a problem where the visible light function didn't work as expected. If you don't get it resolved then you could always disable the visible light option on the light(s) and use some self-illuminated geometry instead.

fabw
04-11-2010, 05:18 PM
I have found sth like that but dont know what is all about.

http://area.autodesk.com/forum/autodesk-3ds-max/maxscript/setting-light-shape-visible-in-rendering-for-a-photometric-light-in-maxscript/

CGTalk Moderation
04-11-2010, 05:18 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.