PDA

View Full Version : Tail rigging problem


martinf430
04-07-2010, 05:02 PM
Hi im fairly new to rigging and im rigging a T rex at the moment. I have rigged a dynamic tail driven by maya dynamic hairs. The tail works fine and drives the joint chain no problem but the problem im having is the tail moves forward when i move the root joint and the tail seems to move at twice the speed as the rest of the rig. Can some one please advise the best way of attaching all my rig to a master control that will move everything equally? thanks.

Dustin
04-07-2010, 07:47 PM
Looking at your screenshots, you have a nurbs curve you are using for the tail, and it looks like it is parented to the rig. This is probably causing a double transform, in which the object's transform node is moving forward, and so is the shape node of the object, which is doubling the movement. Just try unparenting the nurbs curve and see if that fixes it.

giordi
04-07-2010, 07:55 PM
yeah like already said it s a double transformation , parent the nurbs on the root control or anything you want , select the nurbs curve and open the attribute edito and switch on the inherit transformation option

martinf430
04-07-2010, 08:25 PM
Thanks unparenting the ctrl seems to have fixed the double transform...fingers crossed i can get everything on a master ctrl now! Thank you both.

martinf430
04-08-2010, 11:18 AM
Un parenting the tail fixed the problem however now when i parent constrain the ctrl to the global control the problem reappears. inherits transform is already checked on. anyone any ideas how to sort this, thanks
martin.

giordi
04-08-2010, 03:33 PM
sorry the inherit has to be turned off
i created really quick a tail with spline ik and cluster i turned off the inherit for the nurbs curve of the spline and it works fine

Dustin
04-08-2010, 03:52 PM
Just to give a bit of clarity to understand what is going on, I recommend you follow a simple example.
Create a cube, highlight all the vertices, and create a cluster. If you move the cluster handle, you will see the cube move. If you go back to object mode, you will see that the object's pivot has not moved. This is because moving the cluster only moves the geometry, not the object. Now, if you select the cube AND the cluster and translate it, you get the double transform. This is because the object is moving, and the shape is moving, causing the double transform.

giordi
04-08-2010, 03:53 PM
sorry the inherit has to be turned off
i created really quick a tail with spline ik and cluster i turned off the inherit for the nurbs curve of the spline and it works fine

martinf430
04-08-2010, 05:38 PM
Thanks, that helps me understand it a bit better but i have a messy setup i have like 3 curves on the tail, when i attach the tail to the master control it seems to move fine with the master but when i parent constraint the root control to the master this is when it has the problems. il post an image of the setup i have, also il link the tutorial i used for the tail, i followed it pretty much step by step.

http://www.vimeo.com/8240821

Thanks again

martinf430
04-08-2010, 06:26 PM
Seems like iv maybe sorted it, turned off the inherit transform of a few of the curves and it seems to work. Thanks for ur help.

CGTalk Moderation
04-08-2010, 06:26 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.