PDA

View Full Version : Displacement map baking


Izuael
03-26-2010, 02:54 PM
Hello!

I'm working on a character that I have sculpted and want to bake out displacement maps off. I like to bake in Maya, old habit I guess. But I also tried this in xNormal, same effect there.
But I must be doing something wrong because when I bake I always get artifacts in the texture, like there's some imprints left of the lowpoly mesh in the displacement texture. I don't get it why it happens when normal maps get perfectly smooth?

I've tried baking with a mesh that's more subdivided but it only results in a more finer grid pattern all over the texture. I do smooth the normals before I bake.

What am I doing wrong?
I apologize if this is a nooby question, but I've mostly done game art so displacement maps are new to me.

I'll add some example pics of what I am talking about.
http://img514.imageshack.us/img514/7892/displacementtest.jpg

Izuael
04-02-2010, 11:13 AM
Hello again,

I tried exporting the displacement from Zbrush instead, looks much better there. All smooth. But now instead there's a 'hole' along the seam of the mesh that I didn't have before.

http://img63.imageshack.us/img63/8117/displacementtest2.jpg

I'm still curious to know why Mayas displacement bake looks so different. :/

Katzenminze
04-04-2010, 09:24 AM
hi,
if youre baking in maya, make sure you check your baking envelope (its in the menu wher eyou chose what maps to be baked) make sure the envelope includes both low and high poly object.
did you UV it properly? this has a great impact on the texture aking as well.

Izuael
04-07-2010, 09:08 AM
Hello!

Thanks for helping. :)

Yes the baking envelope covered the whole mesh, both low and high. And the UVs aren't overlapping or anything weird. I also smoothed the normals, but it still got that ugly grid pattern in the texture (like 'burn marks' from the lowpoly wire).

But as I said in my earlier post, it worked better in Zbrush. Now it's just a matter of getting rid of the holes along the seam.
I tried troubleshooting, and it seems it has to do with when the mesh subdivides in rendertime, I use a mentalray approximation node that must do something with the UVs so they don't match up exactly with the displace texture. But can't find options for smoothing the UVs or something like that (with mental ray).

surreal-reality
04-14-2010, 11:00 PM
I've found 2 things that cause seam breaks like that in maya are where the uv edges aren't sewn, and if the normals aren't smoothed across that edge.

if you've tried those, then I have no idea.

Izuael
04-16-2010, 08:21 PM
Thanks for trying to help surreal-reality. :)

The normals are smoothed, but the uv is not sewn there. The crack happens along that seam. I hope I don't have to redo the uvs, because it's all textured and done now hehe.

I noticed when I accidently rendered with having subdivided the mesh, there was no hole. So as I said before I think it has to do with the mental ray approximation node or atleast when the mesh gets subdivided in some way. But I'm not sure.

Izuael
06-14-2010, 10:31 PM
Hello again.

I just thought I would post to say that I finally found a solution. For those that might stumble upon this thread in the future.

I found this walkthrough that explained the whole process pretty well. Particularly a melscript by a guy named Scott Spencer that got rid of my seam problem.
http://www.andrewklein.net/bh/differencemapping.html

"It appears that a lot of people are having problems with Maya 2008 and rendering displacement maps. Two major changes have been made in Maya 2008 that impacts the ability to effectively render 32 bit displacement maps. I did some reasearch and set up a mel script that will set up the scene file correctly. Thanks must go to those who found the problems with Maya 2008 early on. ZBC member marcotronic uncovered the CCMesh change.

The changes that Autodesk made are to the Alpha Detection and the mental Ray export mesh at render time. Maya 8.5 and earlier use Subdivision Surfaces at render time when a subdivision approximation node is assigned. Maya 2008 defaults to the CCMesh or Catmull Clark mesh. This is intended to be faster and support tris, ngons, and quads. The problem is it creates seams in the render.

The second change is to alpha detection. Bloated renders occur because Mental Ray is defaulting to not considering Alpha as luminance.

You can set this manually on each file node or change the default setting under Window>Settings and Preferences>Rendering Use maya style alpha detection.
The script I am posting will throw this switch for the scene file returning it to Maya style alpha detection."

I still wonder if any of you know if it's possible to disable this CCMesh manually in case I don't have his script around?

oglu
06-15-2010, 07:13 AM
take a look at these tutorial...
first part is mudbox second maya displacement rendering...
http://www.pixelcg.com/blog/?p=675

Izuael
06-15-2010, 11:22 AM
Ah thanks Oglu, that's a keeper. :buttrock:

CGTalk Moderation
06-15-2010, 11:22 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.