PDA

View Full Version : normla map expic fail!


jthorne19
03-21-2010, 04:40 AM
hi all,

i always seemt o fail with normal maps and i really don't know why but here is my problem below and i will explain as best i can. I made my model in zbrush and then retopologised it in maya using NEX, I then took the low poly model and put it into zbrush to use the uvmaster pluging and go my normap map and exported it back to maya. from there i used x normal and put the low poly and high poly mesh data in there and it gave me my normal map. i also tried generating one from zbrush but that one was naff aswell. can anybody understand why my normal map has turned out this way? they always come out really wrinkly and deformed! please help!! below is a picture of my work and a little explanation.

many thanks



http://img179.imageshack.us/img179/2528/normlamapproblem.jpg

jthorne19
03-21-2010, 04:41 AM
link to bigger pic if needed

http://img179.imageshack.us/img179/2528/normlamapproblem.jpg

thanks

PhuongDPh
03-26-2010, 08:42 AM
maybe you need to create a Tangent normal map instead of Object normal map

jthorne19
03-28-2010, 05:46 PM
thanks for the reply LSPhuong

i normally work in tangents anyway so i am sure that's not the case. When i create the normal map using maya's bake texture menu it creates the normal map fine but for some reason using x normal, it creates artifacts everywhere and i have no idea why. i am going to post the normal map x normal creates. posted belowhttp://img163.imageshack.us/img163/7263/samplednormals.jpg

i have no idea why it makes it like this but it does. the reason i am wanting normal maps to work with x normal is because it will make it easier to produce other maps too. hope people who have had problems getting decent normal maps out of x normal please help me solve thios problem,

kindest regards

catpowerz2001
04-02-2010, 05:19 AM
Try different settings in Xnormal for the Max front/rear ray distance for the low definition mesh. I think it defaults to .5, so try .1 then .05 then .01 then .005........

No expert but I generally find a sweet spot that has the least amount of artifacts. Think it has to do with size of model but I'm not sure.

CGTalk Moderation
04-02-2010, 05:19 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.