PDA

View Full Version : Text anti-aliasing issues


vreb
03-15-2010, 02:24 AM
Hi guys,

I am having some serious issues with the anti-aliasing on my text in my latest composition and can not find a solution anywhere. I have searched through this forum and the usual alternatives on the web, but none of the solutions seem to work for me.

Basically, I have some red text on a white background and and all is well until I rotate the text. As soon as the text is rotated, the anti-aliasing issues occur and all my edges look jagged. I have tried using an expression to position the text and tried changing various colour values too, but nothing appears to work.

I am sure this is a well know problem but I can't seem to find any solutions. Please can someone offer some advice.

Thanks in advance,

vreb

Mylenium
03-15-2010, 07:07 AM
OpenGL? A bitmap font? Please be more specific and provide screenshots.

Mylenium

vreb
03-15-2010, 10:06 AM
Hi Mylenium, thanks for the reply.

I will add some screen shots later when I am back in the office with After Effects. However, the issues only seem to occur when I rotate my text and I am only using the Arial font too. The anti-aliasing is fine when the text is not rotated. I tried exact positioning (Flash has similar problems with fonts and images if not exactly positioned on a full pixel).

I also tried numerous shades of red in case it had anything do do with that, as previous posts about similar problems stated this can be the case. However, it did not help.

Many thanks for your time,

vreb

vreb
03-15-2010, 02:50 PM
Hi guys, so here is an example of the problem I am having> I have tried this on both Mac and Pc and checked colour settings, positioning and available aliasing options. Anyone know what I am missing. Surely you can rotate text without the aliasing issues I am getting?

Cheers,

vreb

Mylenium
03-16-2010, 07:50 AM
Comp at 100% resolution viewed at 50% zoom or something like that?

Mylenium

vreb
03-16-2010, 11:54 AM
Hi and thanks for taking the time to reply again. No, my comp is at 100% and what you see there is hwo it looks after rendering to a .mov at full quality too.

I have had similar problems in Flash over the years and this looks like the same thing. I just thought this would be a common problem and someone would have a quick solution. If I bring my text into After effects already rotated as required, the problem does not occur. Its only when I rotate text in After effects that the jagged edges and anti-aliasing issues occur.

I tried this with some 3d text I exported from Cinema 4D too (.png and tiff with alpha channel). Once imported into After Effects it looked perfect until I again rotated it. However, if I rendered the text out of Cinema 4D with the rotation I needed and then imported it in After Effects it was again perfect.

Anyone experience this before?

Thanks,

vreb

CGTalk Moderation
03-16-2010, 11:54 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.