PDA

View Full Version : Smoothing -Mission Impossible?


erikals
09-04-2003, 02:30 PM
Simple question?

Based on this geometry, is it impossible to get the area by the windows smooth? I noticed I could use the knife tool on the "pipe" over and under the windows to partly fix the problem, but is there another way? I have a feeling I'm forced to add geometry.

sketchyjay
09-04-2003, 03:08 PM
I would make sure that the boolean didn't make any odd geometry. Select either poly next to the problem and use drag to see if any geometry is hidden between them.

try merge to make sure theres nothing there

Try reapply the surface and make sure smoothing is on for them.

sometimes it might work better to subdivide the area or use the knife to add enough geometry that the boolean has more to work with.

It looks like only one window is having the problem so maybe undo the one bad window and move it over slightly and try to redo it.

Hope of of those helps.

Not sure what else to try,

Jay

Facial Deluxe
09-04-2003, 03:08 PM
What's your smoothing angle ?

When looking in top view, are all your windows hole perfectly aligned on a circle ? Can't say from the pic.

erikals
09-04-2003, 04:00 PM
Thank you.

I think I tried everything, even making a simple object from scratch, but same problem occured. Tried all kinds of smoothing values as well. Though were some points I had to weld, which fixed the worst areas. To fix the problem I had to add geometry near the windows and furter up. Strange.

Fixed now.
Thanks for helping :thumbsup:

m_luscombe
09-04-2003, 08:50 PM
The problem with those polys was that they were non-planar (due to it being angled, two points on top, three on bottom, one point would be too far forward.)

You probably could have cleared it up by Shift-T'ing those problem polys.

Fixed is fixed though. Your solution is just as good :)

richcz3
09-04-2003, 09:59 PM
erikals
That's an interesting solution.
Facial Deluxe did ask about your smoothing angle, sometimes changing the values in smoothing can get rid of some boolean problems.

richcz3

erikals
09-04-2003, 10:26 PM
Thanks again. :)

Nope. Using Shift-T (triple) doesn't work. I actually thought that that would have worked too, but the problem remains. Changing the smoothing angle doesn't work either, not in this case.

I think the problem has to do with the difference in the lenght of the polygons. The problem seem to occur because the polygons both are long and because they use more than four points. Therefore, using the knife tool seemed to work.


Unfortunatly the knifing solution won't always work.
Well, luckily these smoothing problems are rare. ;)

erikals
09-04-2003, 10:40 PM
I had an idea about making a "ring" around the windows, but just like with Sub-Patch modeling when trying to fix "stars", all you really do is move the problem around.

CGTalk Moderation
01-16-2006, 01:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.